error in Matlab code exported from ADRV9009 TES GUI

Hi,

I have a customer who exported the Matlab code from ADRV9009 TES (partial code copied below), and is getting the following error when running that code.

Most of the code seems to be working, and it seems to create the rxDataFormatter object correctly, it doesn't seem to like the IntSampleRes object. Maybe a misspelling in there somewhere?

thanks!

Steve

Connected to Zync

Ad9528 arePllsLocked = 1

Talise pllStatus = 3

MCS Status = 10

isArmGood = 1

ARM Loaded Successfully

Talise pllStatus = 7

Error using test (line 164)

No appropriate method, property, or field 'IntSampleRes' for class

'AdiCmdServerClient.TaliseRxDataFormat'.

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

% GainWithFloatingPoint or GainWithNoCompensation

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

%Ensure Stream File has been set to receive Floating Point Data

rxDataFormatter = AdiCmdServerClient.TaliseRxDataFormat;

rxDataFormatter.FormatSelect = (AdiCmdServerClient.RxDataFormatModes.GainCompensationDisabled);

rxDataFormatter.FpNumExpBits = (AdiCmdServerClient.FpExponentModes.TwoExponentBits);

rxDataFormatter.FpRoundMode = (AdiCmdServerClient.FpRoundingModes.RoundToEven);

rxDataFormatter.FpRx1Atten = (AdiCmdServerClient.FpAttenSteps.FpAtten0dB);

rxDataFormatter.FpRx2Atten = (AdiCmdServerClient.FpAttenSteps.FpAtten0dB);

rxDataFormatter.FpHideLeadingOne = (1);

rxDataFormatter.IntEmbeddedBits = (AdiCmdServerClient.EmbeddedBits.Embed1SlicerBitAtLsb);

rxDataFormatter.IntSampleResolution = (rxDataFormatter.IntSampleRes.Integer12Bit2sComp);

Link.Talise.SetRxDataFormat(rxDataFormatter);

%Link.Talise.SetRxDataFormat(TaliseRxDataFormat.0,0,0,0,0,1,0,0,2,0,0,3,3,0,0);