ADRV9002 DPD with custom waveform

Hello, AD experts.

I'm evaluating ADRV9002 DPD with custom waveform.

When I use LTE setup and LTE waveform provided by TES, DPD is quite stable and we can see dramatic improvement.

However, when I use my custom setup and custom waveform, DPD is not stable.

The hardware setup is the same by these two cases.

I read "DPD TUNING AND TESTING" section in UG-1828 and tried to optimize DPD parameters.

However, the results were unstable in any cases.

Our waveform is OFDM like as LTE, but the bandwidth of our waveform is 500kHz, while that of LTE setup is 10MHz.

I would appreciate it if you could advise me to optimize parameters with our waveform.

Best regards,

Kazuyuki

  • Hello Kazuyuki,

    I will bring this issue to our resident DPD expert. In the meantime, do check out the DPD guide we provide in the Documents tab of this forum, available at this link: https://ez.analog.com/wide-band-rf-transceivers/tes-gui-software-support-adrv9001-adrv9007/w/documents/15829/digital-pre-distortion

    We also have a white paper on the way to provide a more advanced perspective on DPD and its usage. I will return once I have further updates for you!

    Best Regards,
    Oisín.

  • Hi, Oisín,

    Thank you for the link. I will do check them.

    Below  are the additional information:

    Version info, LTE results, and our results.

    Attached is our custom setup and tx data. {Removed by OWatkins}

    If there is something wrong or something I should try, please let me know.

    Thank you for your help!

    Best regards,

    Kazuyuki

  • Hello Kazuyuki,

    We're currently running some investigations on your provided files now. I would also like to remind you that this forum is public, so if you'd rather keep your configuration settings quiet we can alter this post to not share your zip file.

    If you are comfortable continuing on this forum, I do have some questions and a few suggestions from our DPD expert:

    • Can you back off the tx input power going into the PA?

    • Do you have a LPF at the input of the PA?

    • Can you check and make sure the feedback power is -18 dBm, this is the peak power not average power.

    • Can you plot the AM/AM plot? We have the API to get captured data, I'll provide the script to do that. and they can send us back the data.

    • Is your waveform phase continuous? I plotted the end and the beginning, it's hard to tell because there are many zeros.

    • (Based on analysis of your waveform, see below) So an additional suggestion is for them to try without DPD or PA, get the waveform to transmit correctly first.
    • Tx filter is not meant to do this, it's only for the FM type modulated data. If they have IQ data, filter it before they send it to interface.

    The most important notice here is that our engineer believes there are issues with your Tx data, your waveform at present does not appear to have a carrier and does not appear to be phase continuous, in the words of our engineer. 

    Do be sure to review what data you're willing to share! We're willing to take this support offline if needed.

    Best Regards,
    Oisín.

  • Hello Oisín,

    Thank you very much for your reply.

    I'd prefer not to open our configuration files.

    Also, it would be better for us to discuss this topic offline so that we can share more information in detail; background, additional results, e.t.c.

    • As to input back off, I'll try and feedback the results later.
    • Yes, we have a LPF at the input of the PA.
    • Yes, the feedback peak power is -18 dBm.
    • I'll try to obtain AM/AM plot and feedback the results later.
    • I will explain about our tx data offline in detail.

    Thank you for your support.

    Best regards,

    Kazuyuki

  • Hello Kazuyuki,

    Understood! I have edited your previous comment to no longer share the zip file. I have a copy which we will use for your support.

    I will reach out to you at my first availability and we will continue this discussion!

    Best Regards,
    Oisín.