AD9081 (4D4AB) rx only: some QC modes not working

Hi!

I'm trying to get AD9081-4D4AB working with the following settings:

FDAC = FADC = 3000 MHz (direct external clock)
Dual Complex mode
CDDC0 = decimate by 2, ZIF, no gain, c2r=0
FDDC0 = decimate by 2, ZIF, no gain, c2r=0
--> total decimation = 4

When using JESD mode 7.00 (LMFS=2221 KNNP=32 16 16 HD=0) it works like a charm!

When using JESD mode 13.00 (LMFS=4211 KNNP=32 16 16 HD=1) it won't leave CGS and also claims the QC mode was invalid. Same for mode 13.10.

Can someone explain to me, why those modes won't work? I feel like I'm getting something basic wrong.

Thanks in advance!

  • , can you please confirm my understanding of your exact use case? 

    FDAC = FADC = 3GHz

    Rx Setup

    CDDC0 = decimate by 2, ZIF, no gain, c2r=0
    FDDC0 = decimate by 2, ZIF, no gain, c2r=0

    M = 2

    N' = 16

    JESD204B

    For mode 7.00, you have a line rate of 15Gbps/lane (because L = 2)

    For mode 13.00, you have a line rate of 7.4Gbps/lane (because L = 4)

    in your experience, mode 13.00 is not working. 

  • Hi UmeshJ, 

    thanks for taking the time to reply!

    We've tried many variations of the parameters, but yes you are correct.

    As you stated, we have tried with 3000 MSps with total decimation 4 and JESD204B, which results in a I/Q output data rate of 750Msps and a 15Gbps lane line rate for 2, and 7.5 Gbps lane line rate for 4 lanes. 

    M is 2, N=N'=16. Mode 7 with 15 Gbps is working, Mode 13 and also Mode 19 does not seem to work. The phase does not establish, the "invalid QC mode" bit is 1 and the link status of the ADC remains CGS.

    Thanks again!