Can't program AD9081 & AD9082 after switching them on same ADS9 carrier board

I'm running into an issue that I think is related to swapping between the AD9081 and AD9082 on the same ADS9 carrier board and would appreciate any suggestions to help debug.
I switched out the AD9081 board (which I've been able to program before) for the AD9082 board, and when I opened up ACE the following happened
  1. The LEDs on the AD9082 eval board light up (all the ones associated with power + HMC status) and current consumption for the whole setup increased from 12V, ~3.45A -> 12V, 4A. Based on previous successful bootups, the setup should consume 12V, ~4.5-5A when fully booted so it looks like the eval board doesn't finish coming up.
  2. After ~10 seconds the current consumption drops to 12V, 0.7A and a red LED DS17 on the ADS9 lights up for a couple seconds (picture below, red LED on left)
  3. The ADS9 reboots, the FMC power is shut down (so the eval board is also powered down), and ACE shows the AD9802 eval board is disconnected
  4. If I try to connect the board through ACE again, the AD9082 fails to power on (no PGOOD LEDs on) or the eval board's PGOOD LEDs turn on but ACE shows "Check Status" failed (screenshot below) so I cannot program the eval board.
I was able to "resolve" this the first time by ssh'ing into the microzed board and running a script in it called `ads9_burn` and rebooting the ADS9. I was able to program the AD9082 afterwards but I'm running into the same issue after swapping the AD9082 for the AD9081 and back again so I don't think that script solved the issue. I'm currently unable to program either AD9081 or AD9082 eval boards as the ADS9 reboots after powering them on. I've attached ACE's AppTrace below.
Here is some additional information about my setup....
  • I'm using the HSX SD Card in the MicroZed board
  • I'm able to ssh into the MicroZed board through Ethernet
  • The BOOT switch is ON (left) when I program the MxFE evalboards with ACE \
  • The BOOT switch is OFF (right) when I ssh into the MicroZed board and run `ads9_burn`
  • ACE is up to date
  • No other instruments are connected 
Has the team ever seen this issue when swapping between AD9081 and AD9082 eval boards on the same ADS9 carrier board, and are there any suggested next steps?


Edit - I've just tried installing ACE onto a new computer and running the above, but see the same issues.
[edited by: youngpines at 11:24 PM (GMT -4) on 11 Oct 2021]
  • 0
    •  Analog Employees 
    on Oct 19, 2021 4:24 AM

    Hi youngpines,

    I'll be trying to find information to help with your question. I don't have an AD9082 board to "swap" with my AD9081 board.

    When you swap between the two boards, are you are powering everything down in-between, and starting from scratch when you have the next intended board connected?

    Thank you.

    Doug

  • Hi Doug,

    Yep, I am power cycling between every step. The flow looks something like 

    1. Turn on 12 V to ADS9 with BOOT ON, wait until I can ssh into the MicroZed board
    2. Launch ACE
    3. AD9081 eval board turns on then ADS9 board reboots
    4. Turn off whole setup and put on AD9082 board
    5. Do (1-3) again but with AD9082

    or

    1. Turn on 12 V to ADS9 with BOOT OFF, wait until I can ssh into the MicroZed board
    2. Run `ads9_burn`. Wait until it finishes
    3. Turn the whole setup off and switch BOOT ON
    4. Turn on ADS9 board, wait until I can ssh into the MicroZed board
    5. Launch ACE
    6. AD9081or AD9082 eval board turns on then ADS9 board reboots

    I think I maybe shouldn't have run the `ads9_burn` script in debugging the first time. Is there more insight into this script?

  • 0
    •  Analog Employees 
    on Oct 20, 2021 10:50 PM in reply to youngpines

    Hi youngpines,

    If you only bring up one board type in ACE, does it come up successfully? Does the issue only appear when you switch between boards, or does the issue now always appear, starting from the time you tried switching boards?

    Does it make sense to go back and try the most basic bringup, all in ACE, or are you able to accomplish that already? Here are the steps I do to bring up my AD9081 evaluation board (AD9081-FMCA-EBZ) in a basic "canned" configuration. My board has onboard clocking.

    1. connect USB, Ethernet and power to the ADS9. Of course the USB and Ethernet cables are connected to a PC which has ACE installed.
    2. power on the ADS9
    3. start ACE
    4. Go to the Home-Start page in ACE. The AD9081 or AD9082 board should be auto detected, and the AD9081 or AD908 plugin icon should have appeared.
    5. Double click on the AD9081 or AD9082 Icon towards the upper left. After several seconds the power LEDs will light up on the AD9081/82 board.
    6. In ACE, select one of the "canned" configurations in the Board View Quick Configuration page and click apply.
    7. After the settings are applied, on the right-hand side of the same Board View in ACE, click on the Navigate to Analysis View block.
    8. In the Analysis View page, clicking on the Run Once button should produce a captured result in the graph on the right-hand side. In the case where no test signal is applied, the time-domain capture will be a flatline, and the FFT will be a noise floor.

    I know this doesn't put the board into any particular configuration that is relevant to your system, but it does show basic functionality. If you are not able to bring up one board in a basic configuration, maybe your ACE installation got corrupted somehow, and a fresh "wipe clean" installation is needed.

    Are you able to bring up one board in a basic configuration?

    Thanks,

    Doug

  • Hi Doug,

    The issue first started happening when I switched out the ADS9 + AD9081 board to a ADS9 + AD9082 setup. And now the issue always appears regardless of which board is plugged in. I'm not able to bring either board up in a basic configuration.

    For the steps you recommended, I can do steps (1-5) successfully but can't do steps (6-8) and there are 2 things that happens. Either

    1. ACE freezes up and then crashes so the window disappears
    2. ADS9 reboots

    Or

    1. Or, ACE will freeze up for a few seconds 
    2. ACE will say AD9081/2 board is not connected and it can't talk with the board or program it. AD908x eval board's LEDs are on and I can ssh into the MicroZed board

    I tried installing ACE onto a separate laptop and see the same issues. The AppTrace log from ACE I think suggests an issue with programming the registers on the eval board or FPGA.

    The picture is from the bottom of the same AppTrace log I linked to in my original post. This trace log was taken after ACE crashed.

  • 0
    •  Analog Employees 
    on Oct 21, 2021 2:06 PM in reply to youngpines

    Hi youngpines,

    Can you check the connection to your MicroZED? There is a short section in UG-1828 about this.

    Thank you.

    Doug