Low output power from the ADRV9361

Hi,

I'm seeing only -26 dBm output power from the ADRV9361-Z7035 at 6 GHz, and around -15 dBm at 100 MHz.

I'm using a simple GNU Radio FMComms2/3/4 sink with a constant source.

With max hold on the analyser at 6 GHz I get up to -18 dBm during startup, before it falls back to -26 dBm. There is 0 dB TX attenuation applied, and I am using the supplied U.FL to SMA adapter cable.

Thanks,

Alex



Changed Z035 to Z7035
[edited by: AlexJCole at 8:29 AM (GMT 0) on 3 Oct 2019]
Parents Reply
  • Hi Alex, I ran into the same problem for the 9361 SOM.  It turns out there is a known issue with the output power of the ADRV9361 SOM.  Perhaps its true for the ADRV9364 SOM also.  But here's what the ADRV9361 SOM looks like for various Tx outputs:

    This is a known issue for Rev E, and I believe a Rev F is in progress to fix it:

    https://wiki.analog.com/resources/eval/user-guides/adrv936x_rfsom/hardware#revision_f_wip

    I'm told that the the Tx power droop, at higher freqs, is due to the pull up inductors being on the opposite side of the board. The attenuation is related to the length of the traces that connect the bias inductors to the Tx RF traces. They’ve addressed the layout issue on Rev F, which unfortunately isn’t finished yet but it is showing a good output power response across frequency. The different Tx ports perform significantly differently across freq on Rev E so you might see benefit to switching the Tx port. 

Children
  • Hi Jon,

    Thanks for your response, I really appreciate the effort you put into it.

    It's good to know that there's nothing wrong with my application, though it is rather annoying to have such wildly different power profiles for each Tx port. As luck would have it, the SoM is driving an LO chain which features a couple of over-performing amps and several over-performing filters, resulting in a drive level which falls perfectly within an acceptable range - so no harm done for the current application.

    Thanks again!