ADRV9026HB EVM less

Hi,

We are using 13NLS JESD204B profile and have tested data path with LTE waveforms. Since, Balun match is from 2.8 - 6 GHz, I have tested at different frequencies. Please find the attachment of the same. 

EVM is observed less in this platform, while the same on previous platform AD9375 was giving  EVM appx. - 42 dB EVM. Any suggestions on it? TIA



.
[edited by: rakshi at 4:54 AM (GMT -5) on 30 Jan 2021]
Parents Reply
  • 1. Same waveform file is proven to give -42dB EVM on AD9375, we are testing with 9026 EVAL board + custom FPGA board as of now.

    2.  We have not modified/added anything to the base code related to calibrations. Should we have to integrate/enable any init/tracking calibrations?

    3. Clock is clean and fine, clock source from the signal generator also didn't help. 

    Any further pointers/suggestions to loop upon? Thanks

Children
  • 0
    •  Analog Employees 
    on Mar 3, 2021 8:34 AM 1 month ago in reply to rakshi

    To achieve -42 dB EVM you need to run all init calibration (Including EXT LoL Init) and Tracking calibrations (Including EXT LoL Tracking).

  • Init calibrations

    Channelmask - 0x0F, Calmask is set to 0xF0D37FF -  which is according to latest SW release notes and also as suggested in the ADRV9026 calibrations overview in the design support forum.

    Also, tried calmask - F0D 3FFF - D11 bit set which is Tx LO leakage external initial calibration.

    Tracking calibrations 

    TX/RX QEC,LOL,DPD were enabled with the API function adi_adrv9025_TrackingCalsEnableSet and tried. 

    EVM is observed to be ~ -37.2 dB at 3.5GHz CF in all the cases 

  • 0
    •  Analog Employees 
    on Mar 4, 2021 5:23 PM 1 month ago in reply to rakshi

    we tried the same in our lab at the same frequency of 3.5GHz, and was able to achieve -40dB EVM. Make sure that you are initializing the board at 3.5GHz(same as your operating frequency) and also run external LOL and QEC tracking. 

  • Hi, with the tracking and init calibrations enabled (0xF0D37FF), we could see 4dB significant change in EVM at 800MHz CF(-43 dB), not so much change in the mid range frequencies. As we were checking EVM at 3.5GHz CF, sometimes/some runs now I see -40dB but mostly I had seen till now is around -38dB.

    Did a sweep test across the frequencies, below are the results,

  • 0
    •  Analog Employees 
    on Mar 8, 2021 3:02 PM 1 month ago in reply to rakshi

    Are you using the same HB board for checking the EVM at lower frequencies? The difference in EVM at lower frequencies is because of better LO phase noise at lower frequencies. As asked before, did you try initializing the board with LO frequency set to 3.5GHz(all the init cals enabled), and then check the EVM at 3.5GHz? You should be able to achieve -40dB EVM.

  • Yes using the same HB board. Yes, we are initializing the board with lopll1 and lopll2 frequencies set to 3.5GHz with all the init cals enabled. 

    I didn't understand what you exactly meant by this -> did you try initializing the board with LO frequency set to 3.5GHz(all the init cals enabled)

    Without initializing the LO2 PLL frequency at 3.5G, how could we see the waveform at 3.5G? Sorry if I am missing something., are the board init frequency and LO operating frequency different ?