configure the adrv9002 sample rate to 12.8MHz/25.6MHz

Hi all , we are working with 7z035+adrv9002 custom board . we previously worked on a project which it's logic assume that the sampling rate of the transceiver is 12.8MHz/25.6MHz.

now, due to wide rf band of the adrv9002 we want to use this rf transceiver but still have the chance of using sampling rate of 12.8MHz/25.6MHz . now from the TES evaluation software of the adrv9002 we can see that we can't reach the required sample rates (we presume maybe because of the API or due to the transceivers PLL's).

how can we reach those sampling rates(12.8MHz/25.6MHz) with the adrv9002 transceivers.

with best regards.

SDR team   

  • +1
    •  Analog Employees 
    on Aug 4, 2021 3:27 PM

    Hello darroz,

    The internal system clock must be in a valid range to make the system work properly, sample rate 12.8 / 25.6Mhz violates this rule. So by default this isn't supported by TES.
    However, TES offers a "Custom Extended" mode, this will allow the system to be used with some lower restrictions. You should give this mode of operation a try, you will get a warning from TES to let you know that the safety systems in TES have been slightly lowered but you should be okay.
    Do let me know if this works out for you!
    Best Regards,
    Oisín.
  • Hi Oisin , with regards to the custom extend mode , does it avilable from a certain version ?( in my version i couldn't see this kind of mode )

    What i need to do in order to enable thia kind of mode ? 

    Thanks

    -Dror

  • 0
    •  Analog Employees 
    on Aug 5, 2021 6:00 AM in reply to dror\

    Hello Dror,

    For Custom Extended mode you need SDK v0.16, so if you update to the latest version available on analog.com you'll have access to the Custom Extended setup.

    Best Regards,
    Oisín.

  • Hello Oisin , we downloaded the new SDK v.016 of the TES and configured the parameters as follows :

    * the json file is also included here (please pay attention that despites the name of the files as CMOD....json the parameters were defined to the LVDS configurations ) 

    but when trying to load the new profile to the custom board device using cat command we got this errors .

    but the files can be found on the device as you can see 

    why can't I load the profiles ?the same method worked for me with version 0.14v of the TES 

    I will appreciate your answer ASAP due to deadlines that getting pretty soon with our projects .

    with best regards .

    Dror

     CMOS_NAVASSA_STREAM.rar

  • 0
    •  Analog Employees 
    on Aug 5, 2021 3:46 PM in reply to dror\

    Your paths are wrong as the error states.

    Change /home/root -> /root in your commands

    -Travis