AD9371 Eval Board on Zynq3 with Matlab R2019a on linux

I searched through the forum, but didn't see anything quite like my problem, so hopefully this isn't redundant.

I'm running Ubuntu 18.04 and Matlab R2019a with Signal Processing, DSP and Communications toolboxes, but not Simulink or HDL Coder. I can connect to my AD9371 eval board connected to a Zynq3 eval board directly (ssh) and I can run IIOscope. I downloaded the AnalogDevicesBSP_v18.2.mltbx from, but when I open it in Matlab it says "Incompatible Toolbox... You are installing content that is not supported for this MATLAB release or for this platform". I'm assuming it won't work, but I don't get further errors when I click OK. However, if I try to create a receive or transmit object, e.g., rx = adi.ADRV9371.Rx, set the IP, then run rx() I get

Not enough input arguments.

Error in matlabshared.libiio.base/enableChannel

Error in adi.common.RxTx/configureChanBuffers (line 104)
enableChannel(obj, obj.channel_names{k}, obj.isOutput);

Error in matlabshared.libiio.base/setupImpl

So I tried to download the source and build it, but it appears I need Vivado, plus it can't find even though it's located in the directory I ran 'make -C CI/scripts build' from. For now, I don't need to modify the FPGA, but if it's not possible to access the 9371 without Vivado then I'm stuck.

I also tried the following in Matlab.
>> dev = sdrdev('AD936x', 'IPAddress', '')

dev =

SDRDevAD936x with properties:

IPAddress: ''
DeviceName: 'AD936x'

>> testConnection(dev, '')
## Pinging host IP address
## Pinging radio IP address
## Checking compatibility of software with hardware
Error using
Error attempting to connect to address ''.

Error connecting to SSH server at
This could be due to:
- an improperly specified device IP address
- an unsuccessful boot from SD card image
- an improperly configured network card on the host
- an incompatible network card on the host
- host port blocking or anti-virus software

See the documentation to configure the host and SDR device for proper communication.

I'm guessing that's because the SD card that allows IIOscope to run on my host computer isn't the right one for the Matlab interface, yes? I don't currently have an SD reader to use with the Ubuntu machine, but I will soon. But if this should work from the boot image that allows me to ssh to it and run IIOscope, then that's not the problem.

Any ideas?