there is a black gap at the top of image


Hi expert

       There is a black gap at the top of image when using a external Signal Generator(NTSC-M) .

However,image produced by chips(adv7282m 480P) themselves is 720x480 size is normal.

Please refer to the attached file to get detailed description.

I hope to get your help,thanks!

adv7282mdisplayissue.zip
Parents
  • Hi Yuanyuan Guo,

    Do you see this issue with NTSC inputs but not PAL inputs ?

    If so the issue is probably due to the output format from the ADV728x.

    By default the ADV728x will output in ITU BT656-3 timing format (this is true for MIPI CSI-2 output models too).

    If the receiver chip is expecting ITU BT656-4 format then this can result in 10 dark lines appearing at the top of the screen in NTSC mode. This is because ITU BT656-3 format has 10 more lines of vertical blanking than ITU BT656-4 format.


    You can program the ADV728x to output in ITU BT656-4 format. Set User Map, register 0x04 bit[7] to 1. This should solve your issue.


    Regards,

    Robert Hinchy

    Senior Applications Engineer,

    Digital Video Products Group,

    Analog Devices Inc.

Reply
  • Hi Yuanyuan Guo,

    Do you see this issue with NTSC inputs but not PAL inputs ?

    If so the issue is probably due to the output format from the ADV728x.

    By default the ADV728x will output in ITU BT656-3 timing format (this is true for MIPI CSI-2 output models too).

    If the receiver chip is expecting ITU BT656-4 format then this can result in 10 dark lines appearing at the top of the screen in NTSC mode. This is because ITU BT656-3 format has 10 more lines of vertical blanking than ITU BT656-4 format.


    You can program the ADV728x to output in ITU BT656-4 format. Set User Map, register 0x04 bit[7] to 1. This should solve your issue.


    Regards,

    Robert Hinchy

    Senior Applications Engineer,

    Digital Video Products Group,

    Analog Devices Inc.

Children
No Data