ADV7393 as black burst generator but problem locking to external H/V

I've seen the message: Using ADV7393 as black burst generator

I want to do the same, I'm using slave SD Timing Mode 1 (using HSYNC and Field), connected a 27Mhz clk and left the pixel data P[7:0] connected to GND.

But i have a problem getting the analog video output to frame align on the sync inputs. It is locked to the pulses but it starts random not locked to the Field. I've tried reseting the internal SD timing from the ADV7393 by setting bit7 from register 0x8A.

But then it randomly starts with its frame

Best Regards

Teun

Parents
  • Shifting/delaying of the external H and field pulses doesn't change the video output timing.

    My i2c settings are:

    0x17 0x02 // reset

    0x00 0x1c // enable all DAC's

    0x01 0x00 // SD only

    0x02 0x24 // Set black output

    0x8c 0xcb //sub carrier freq

    0x8d 0x8a   

    0x8e 0x09

    0x8f 0x2a

    0x80 0x11 // PAL BDGHI

    0x8a 0x0a // SD Timing Slave Mode 1 Ext:Horz/Field

    0x8a 0x8a // SD timing reset

    0x8a 0x0a // No SD timing reset

Reply
  • Shifting/delaying of the external H and field pulses doesn't change the video output timing.

    My i2c settings are:

    0x17 0x02 // reset

    0x00 0x1c // enable all DAC's

    0x01 0x00 // SD only

    0x02 0x24 // Set black output

    0x8c 0xcb //sub carrier freq

    0x8d 0x8a   

    0x8e 0x09

    0x8f 0x2a

    0x80 0x11 // PAL BDGHI

    0x8a 0x0a // SD Timing Slave Mode 1 Ext:Horz/Field

    0x8a 0x8a // SD timing reset

    0x8a 0x0a // No SD timing reset

Children
No Data