adv7283 EAV SAV

I use a custome board with ADV 7283

My Microcontroller interface accepts:

FrameStart XY

FrameEnd XY

LineStart XY

LineEnd XY

to parse the

FF 00 00 XY -> EAV/SAVs

i have interlaced 864X288Pixels PAL CVBS

(i think with blankings in it should be 720X288interlaced  ->(720X576progressive) Active)

I use XY codes:

0x80 SAV       0x9D EAV    ->EvenFrame

0xC7 SAV     0xDA EAV    ->OddFrame(or mixed)

i assume that the Stream ITU-R BT 656 works like this:

|SAV(even) | Line 1| EAV(even)| |SAV(even) | Line n| EAV(even)|

|SAV(odd) | Line 1| EAV(odd)| |SAV(odd) | Line n| EAV(odd)|

mixed into this should be

  ...|SAV(even,Blanking)| 80 10 | EAV(even,Blanking)|...

So i used:

FrameStart 0xDA

FrameEnd 0xC7

LineStart 0x80

LineEnd 0x9D

but i get blanking data into my buffer:

...81 01 00 00 00 DA

80 10 times 25

00 C7 81 01 81 01 ...

>>>How should i setup my Frame Start/End Line Start/End ?

-are my assumptions correct?

-i am satisfied if i can catch one Frame (even OR odd) at once.

Then i could swap the configuration and catch the other one.

Parents
  • 0
    •  Analog Employees 
    on Aug 2, 2018 3:37 PM
    This question has been assumed as answered either offline via email or with a multi-part answer. This question has now been closed out. If you have an inquiry related to this topic please post a new question in the applicable product forum.

    Thank you,
    EZ Admin
Reply
  • 0
    •  Analog Employees 
    on Aug 2, 2018 3:37 PM
    This question has been assumed as answered either offline via email or with a multi-part answer. This question has now been closed out. If you have an inquiry related to this topic please post a new question in the applicable product forum.

    Thank you,
    EZ Admin
Children
No Data