18bit RGB video to ADV7513

Hello,

I have selected ADV7513 to convert 18bit/24bit RGB video to DVI or HDMI (only video). and I have used evaluation board schematic, hardware user guide and created schematic of ADV7513.

currently I am sending only 18bit RGB data only (no LSB i.e. R2-R7, G2-G7 and B2-B7), but I could not get video output.

do we need to change any register configuration or circuit components for 18bit RGB input?

  • 0
    •  Analog Employees 
    on Jan 2, 2017 1:29 PM

    Hi,

    Do you have one of our evaluation board for ADV7513?

    How do you configure the board either through script or through software driver?

    What specific script are you using from design support files?

    Did you try this on evaluation board and observe same behavior?

    Best Regards,

    Jeyasudha.M

  • Hi Jeyasudha,

    We have made a dedicated PCB (circuit attached), eventhough we have AD7611 evaluation board. We have not done any software configuration, but as mentioned in previous post we are using only RGB 666. Do we need to configure via software for 18bit RGB input video (no audio)

  • 0
    •  Analog Employees 
    on Jan 4, 2017 9:50 PM

    There should not be an issue transmitting 18bit source data

    1) tie off bits 1..0 to ground just to be safe.

    2) program the 7513 for 24 bit RGB input.  One of the standard scripts should work.

    Q1) Are the TMDS lines floating at ~3V dc?

    Q2) Do you see the pixel clock on the TMDS clock line?

  • hi,

    I am working with Mr. Anand,

    These are the waveforms we are getting from the TMDS Lines of the EVAL-ADV7612-7511P Evaluation Board (both at the Receiver (Port A of ADV7612) input and Transmitter (ADV7511) Output.

     

    The same is the case for all the other TMDS data Lines. All of them float at 3.3 V DC

    The input fed to Port A of ADV7612 is from PC and the output port of ADV7511 is observed in the monitor. The monitor is either showing a ‘No Signal’ indication or a plain Blue Screen.

    We also configured the board with default available Script. But the result is the same.

    The default scripts tried are:

    • 6-1d Port A, 480i,576i,240p,288p,480p 576p Any Color Space In (YCrCb 444 36bit from ADV761x) Through HDMI Out 36-bits 444 YCrCb (Fast Switching)VIC[1-3,6-14,17,18,21-29,30]
    • 6-1e Port A, 720p,1080i Any Colorspace In (YCrCb 444 36bit from ADV761x) Through HDMI Out 36-bits 444 YCrCb (Fast Switching)VIC[4,5,19,20]
    • 6-1f Port A, 1080p Any Colorspace In (YCrCb 444 36bit from ADV761x) Through HDMI Out 36-bits 444 YCrCb (Fast Switching)VIC[16,31,32]

    We tried with another video source with 320x 480 resolution and 30 frames per second. But we tried it for ADV7513. We didn’t get the output for that also.

    Any help would be appreciated.

  • 0
    •  Analog Employees 
    on Jan 13, 2017 6:19 PM

    The TMDS lines should be approximately 3V with +- 300mV signal riding on them.  The clock pair will be the pixel rate.  The data pairs with be 10x the pixel rate.

    Looking at the waveforms, you are not transmitting at all.

    Is the ADV7511 HPD signal high?  If low then the transmitters are turned off. There is a way to programmatically orveride this automatic feature.