Post Go back to editing

EVAL-ADV7182AEBZ_HSYNC_VSYNC_Abnormal Timing

Category: Software
Product Number: ADV7182
Software Version: DVP Eval Latest Source 10-14-11.exe

Dear Sirm,

We use DVP Eval Latest Source 10-14-11.exe on EVAL-ADV7182AEBZ.

It happen the following symptom.

<Symptom Detail>

AN1/Input Format:  NTSC 

Using Script File:Scripts-> ADV7182A_CUST->02_CVBS_SINGLE_ENDED_AUTODETECT->Autodetect_CVBS_Single_Ended_In_Ain_1_YPbPr_Out

We checked Hsync and Vsync pin by oscilloscope.

-It  sometimes happen abnormal of the rising timing of HSYNC and VSYNC (it sometimes work normally.)

 It is unstable behavior of VSYNC.

   -Normal case : VSYNC is same rising timing as HSYNC. (HSYNC and VSYNC rise at same time.) 

   -Abnormal case : VSYNC is different rising timing,shiftted(delayed) by 2 clock from HSYNC.

 At reading timing of the script file, it may be normal or abnormal. (dependent on read script file timing)

Could  you please advise us about this symptom?

Thanks and Best regards

Kida

 

  • Hi Isshinkida San,

          Generally, the timing of the HSync/VSyncs are determine what is blanking and what is active video, basically the state of VSync when there is an HSYNC transition determines whether the change is to active video or blanking and 'Vsync' to be low only when any format change.

            Please note that, We can have the certain possibilities for HSYNC/VSYNC Abnormality.

                  1. There might be a problem with crystal frequency ( Is it 28Mhz or 28.63636Mhz? It has to be the right frequency.  The offset is definitely a problem as well-- if you are using the same bias circuit as the eval board it should be the same offset.  You should probably check the components in that circuit and check for shorts.

                  2.  The PLL filter/Power supply is the most likely be an problem (PLL (PVDD) power supply might be an noisy ).

         .        3. Please ensure with source, for example If the source is inputting a strange Vsync timings then this timing and that will be reflected through the entire path. (Hsync and Vsync are encoded in the same symbol in the input video stream.  Therefore they should be whatever the source is outputting).

    Note:  

    H & V Sync timings are all based on the VESA, SMPTE or CEA standards depending on the resolution. So the respective resolution timing details we can get it from standards specification.

    These details we need to look at the timing specifications from CEA861-E or any other reference document like Video Demystified book ( video-demy5.pdf ) .


    Thanks,

    Poornima

  • Dear Poornima-san,

    Thank you for your reply and support.

    This symptom happen on  EVAL-ADV7182AEBZ with script file ,ADI evaluation board and provided software.

    Therefore we think that  the crystal frequency ,power supply filter and register setting are no problem.

    We will check to happen dependent on input source.

    We have one more question.

    Are there posibility that H/Vsync happen synchronization error change  by register setting timing?

    For example, input signale then setting resiter. Setting resiter then input signal.

     At writing to the script file, the symptom is chanded normal or abnormal behavior (it is dependent on writing script file timing)

    Thanks and Best regards

    Isshin Kida

     

  • Dear Poornima-san,

    >>We will check to happen dependent on input source.

    We checked some input source, signal generator, BD Player.

    It also happen same symptom.We think that this cause is not related with input source.

    Could you please advise us again?

    --------------------------------------------------------------

    This symptom happen on  EVAL-ADV7182AEBZ with script file ,ADI evaluation board and provided software.

    Therefore we think that  the crystal frequency ,power supply filter and register setting are no problem.

    And it happen this symptom at some input source. 

    We have one more question.

    Are there posibility that H/Vsync happen synchronization error change  by register setting timing?

    For example, input signale then setting resiter. Setting resiter then input signal.

     At writing to the script file, the symptom is chanded normal or abnormal behavior (it is dependent on writing script file timing)

    -----------------------------------------------------------

    Thanks and Best regards

    Isshin Kida

  • Hi IsshinKida San,

         Its not required to adjust the timing related registers because default values generally introduce zero timing shift.

         Please let us know, Are you observing this Sync abnormality even with PAL input ?

         If Possible, Please share that output timing waveform.

         Also note that during reset this sync pins will go into the undetermined state.

        Please ensure during power-up, the reset pin is held low for at least 5ms after the 3.3V, 1.8V and power-down lines go high. After the reset pin goes high, wait for at least 5ms before starting I2C communication.

        

    Thanks,

    Poornima

  • Dear Poornima-san,

    Thank you for your reply.

    We shared NTSC and PAL waveform at OK/NG case.

    <NTSC Waveform>

    <PAL Waveform>

     

    And we chekced power line and reset and set register setting timing on EVAL-ADV7182AEBZ.

    It shoudl be no problem because of  ADI evaluation board.

    Could you please advice us about this symptom again?

    Thanks and Best regards

    Isshin Kida

  • Hi  IsshinKida San,

           In our eval board, none of the customer been reported this sync timing shift So if Possible could you please check with any other evaluation board.

    Thanks,

    Poornima

  • Dear Poornima-san,

    Could you please share your script file that you use on your evaluation board?

    Maybe our script file is wrong.

    Our procdure is as follows.

    Step1: Power on evaluation board.

    Step2: Connecting source equipment with AN1

    Step3:Power on source equipment

    Step4: Start software "DVP Eval Latest Source10-14-11.exe"

    Step5:Load Script file"Autodetect_CVBS_Single_Ended_In_Ain_1_YPbPr_Out"

    Step6:Re-Load  same script file

    --> Repeating Step5 and Step6 then it happen this symptom.

    Thanks and Best regards

    Isshin Kida

  • Hi IsshinKida San,

           Here I don't have ADV7182AEBZ eval board to check the reported scenario.

           In previous comment i stated like, "None of the customer been reported this sync timing shift in our eval board".

       Could you please follow below procedure and let us know the result,

    Step1:  Power on evaluation board.

    Step2:  Connecting source equipment with AIN1.

    Step3:  Power on source equipment.

    Step4:  Start software "DVP Eval Latest Source10-14-11.exe"

    Step5:  Load Script file"Autodetect_CVBS_Single_Ended_In_Ain_1_YPbPr_Out"

    Step6: Run Script file

    --> Don't Repeat Step5 and Step6 .

    Thanks,

    Poornima