Post Go back to editing

Can't RXB as ADV7626 receive 1366x768?

I asked this question before.

Can't ADV7625 receive 1366x768 at Transceiver mode (non mux mode) ?
ez.analog.com/.../can-t-adv7625-receive-1366x768-at-transceiver-mode-non-mux-mode

A similar problem occurred again.

If RXB is input 1366x768, Monitor is unstable.

<Composition>

【CASE1】MUX and NON MUXmode doesn't matter

HDMI(1920x1080)→RXA(RX1)・・・TXA→Monitor1 ※stable
HDMI(1920x1080)→RXB(RX2)・・・TXB→Monitor2 ※stable

【CASE2】MUX and NON MUX mode doesn't matter

HDMI(1366x768)→RXA(RX1)・・・TXA→Monitor1 ※stable
HDMI(1366x768)→RXB(RX2)・・・TXB→Monitor2 ※unstable

【CASE3】Splitter mode①

HDMI(1366x768)→RXA(RX1)・・・TXA→Monitor1 ※stable
                ・・・TXB→Monitor2 ※stable


【CASE3】SPlitter mode②

HDMI(1366x768)→RXB(RX2)・・・TXA→Monitor1 ※unstable
                ・・・TXB→Monitor2 ※unstable

I think that it is need to change register for display 1366x768 on the monitor steady.

Please give me some advices.

Best regard.

Parents
  • Hi,

       If 1366x768 format is working on RXA port means, then it should work on RXB port also.

       Could you please share your register configuration.

    Thanks,

    Poornima

  • Hi,

      Please make sure with below things when you connecting the RXB in splitter mode & let us know the result,

            When you connecting the signal source to RXB in splitter mode,you have missed to enable the RXB configuration in  RX1_PORT_SEL register as 001 for RXB port.

             Both RX1_PORT_SEL and RX2_PORT_SEL should be configured for RxB port.     

             Please change the B2 01 register value according to that (i.e B2 01 19).

             Then you will get the expected output in RXB as splitter mode.

    Thanks,

    Poornima

  • Dear Poornima-san,

    Thank you for your reply.

    Please refer the attached file, ADV7626 all configuration valuse.

    Could you please check it and advice us?

    ADV7626.zip

    BR.Kida 

  • Hi IsshinKida San,

      1366x768 graphic format should work for RxB port also, Could you please try below configuration and let us know the result.

    B0 00 D0 ; default=0xF3, Power Up DPLL_A, xtal
    B8 41 10 ; default=0x50, Power up TxA
    F8 41 10 ; default=0x50, Power up TxB
    4E B5 00 ; default=0x01, DPLL_A Set 128Fs MCLK Out
    B0 01 97 ; default=0x01, HDMI Receiver Rx1 enabled, RxB-Rx1, Reserved-Rx2
    B0 02 20 ; default=0x00, Enable Splitter Mode
    B0 04 66 ; default 0x26, Bypass CP Lite B in Splitter Mode
    B0 08 11 ; default=0x00, Tx Audio Insert Config - Audio Rx1-TxA, Audio Rx1-TxB
    B0 09 11 ; default=0x55, ADI Required Write
    B0 0A 11 ; default=0x00; Rx Audio Extract Config - Audio Rx1-AP1_OUT and Audio Rx1-AP2_OUT
    B0 0F 0C ; default=0x08, Audio Input Ports Config - Use AP1_IN and AP2_IN ports as the Audio Input Ports
    B0 B1 1A ; default=0x9A, Hot Plug Config - configure as required in system
    ; B0 B2 1F ; default=0x00, Set Hot Plug
    B0 B3 DF ; default=0xBF, ADI Required Write
    B0 9D 00 ; default=0xFF, Turn off tristate on AP1_OUT
    B0 9E 00 ; default=0xFF, Turn off tristate on AP2_OUT
    44 C9 2D ; default=0x2C, CP_Lite_A Disable Auto Parameter Buffering - ADI Required Write
    94 C9 2D ; default=0x2C, CP_Lite_B Disable Auto Parameter Buffering - ADI Required Write 

    Thanks,

    Poornima

  • Dear Poornima-san,

    We tried your advice setting.
    But it can't display any resolution.(it can't even display at 1080p)
    Could you please check your suggestion register value again?

    BR Kida

  • Hi IsshinKida San,

       Above register settings should work, Could you please crosscheck with our ADV7625 eval board ?

    Thanks,

    Poornima

  • Dear Poornima-san,

    We checked it gain.But it can't display on your suggetion register values.

    About "B0 00 D0 ; default=0xF3, Power Up DPLL_A, xtal",  this value "HDMI RX1 and HDMI RX2" are Power-down mode.We think that it doesn't display on this value.

    Therefore we tried to modfy "B0 00" valuse to 0x50h ffrom 0xD0h.It can display at 1080P60Hz.

    But It still can't display both TxA and TxBat 1366x768 resolution.

    Could you please advise us addtionally?

    BR,Kida

  • Hi IsshinKida San,

            Let me check the 1366x768 resolution in RXB port using our ADV7625 eval board and let you know the status tomorrow.

    Thanks,

    Poornima

  • Hi IsshinKida San,

            Here we have verified the '1366X768' resolution in RXB port using our ADV7625 eval board and we could able to get the output & seems working fine .We have used VG871B as source and VA1838 as sink  for validating these format

          

           Could you please check with our ADV7625 software driver at https://ez.analog.com/video/w/documents/698/advantiv-eval-adv7625-smz-video-evaluation-board

    Thanks,

    Poornima

  • Dear Poornima-san,

    Thank you for your checking.

    I understood that you can't duplicate this symptom on EVB.

    Please tell us about your testing about "B0 00 register".

    What value did you set on  "B0 00" register when testing? (Which "B0 00 50 " or "B0 00 D0"  did you set?)

    "B0 00 D0"  value is Power down mode.Therefore we think that  it should set ""B0 00 50 ".

    Please tell us again about your verification register value on EVB that you did test? 

    BR Kida

  • Hi IsshinKida San,

               Yes you are right, we need to power-up the HDMI RX1 for splitter mode, Please configure Power-Down Control register as "B0 00 50" and let us know the result.

    Power Up Rx1 after Rx Config - ADV7625/26 HDMI Splitter Mode:
            B0 00 50 ; default=0xF3, Power Up Rx1, DPLL_A, XTAL
    End

    Thanks,

    Poornima

  • Dear Poornima-san,

    Sorry, my response is late.

    This issue was closed, thank you for your support.

    BR kida

Reply Children