Post Go back to editing

Can't RXB as ADV7626 receive 1366x768?

I asked this question before.

Can't ADV7625 receive 1366x768 at Transceiver mode (non mux mode) ?
ez.analog.com/.../can-t-adv7625-receive-1366x768-at-transceiver-mode-non-mux-mode

A similar problem occurred again.

If RXB is input 1366x768, Monitor is unstable.

<Composition>

【CASE1】MUX and NON MUXmode doesn't matter

HDMI(1920x1080)→RXA(RX1)・・・TXA→Monitor1 ※stable
HDMI(1920x1080)→RXB(RX2)・・・TXB→Monitor2 ※stable

【CASE2】MUX and NON MUX mode doesn't matter

HDMI(1366x768)→RXA(RX1)・・・TXA→Monitor1 ※stable
HDMI(1366x768)→RXB(RX2)・・・TXB→Monitor2 ※unstable

【CASE3】Splitter mode①

HDMI(1366x768)→RXA(RX1)・・・TXA→Monitor1 ※stable
                ・・・TXB→Monitor2 ※stable


【CASE3】SPlitter mode②

HDMI(1366x768)→RXB(RX2)・・・TXA→Monitor1 ※unstable
                ・・・TXB→Monitor2 ※unstable

I think that it is need to change register for display 1366x768 on the monitor steady.

Please give me some advices.

Best regard.

Parents
  • Hi,

       If 1366x768 format is working on RXA port means, then it should work on RXB port also.

       Could you please share your register configuration.

    Thanks,

    Poornima

  • Hi,

      Please make sure with below things when you connecting the RXB in splitter mode & let us know the result,

            When you connecting the signal source to RXB in splitter mode,you have missed to enable the RXB configuration in  RX1_PORT_SEL register as 001 for RXB port.

             Both RX1_PORT_SEL and RX2_PORT_SEL should be configured for RxB port.     

             Please change the B2 01 register value according to that (i.e B2 01 19).

             Then you will get the expected output in RXB as splitter mode.

    Thanks,

    Poornima

Reply
  • Hi,

      Please make sure with below things when you connecting the RXB in splitter mode & let us know the result,

            When you connecting the signal source to RXB in splitter mode,you have missed to enable the RXB configuration in  RX1_PORT_SEL register as 001 for RXB port.

             Both RX1_PORT_SEL and RX2_PORT_SEL should be configured for RxB port.     

             Please change the B2 01 register value according to that (i.e B2 01 19).

             Then you will get the expected output in RXB as splitter mode.

    Thanks,

    Poornima

Children