ADV7513 VIC#15 SCRIPT

Hello

 

Im using ADV7513 chip with the below configuration:

ycbcr 422, 480p 2x clk, de enable (VIC #15)

 

Tried to use  bt656-ADV7842_7511-hdmi-480pi.txt (with ":8-bit bus separate syncs DE,VS,HS") without luck.

0x3E is detecting VIC#49 (480p-120, 16:9) 

Where can i find script for detecting VIC #15

  • 0
    •  Analog Employees 
    on Jun 2, 2017 11:31 PM

    Hi

    Do you have one of our evaluation board for ADV7511 or 7513?

    Are you using any specific script from design support files  to configure the board?

    Did you do the test on the evaluation board and observe the same behavior?

    We recommend that customers who are evaluating ADV7511/ADV7513 purchase an evaluation board like EVAL-ADV7612-7511 and work with it to get the scripts up and running

    Did you try the scripts available in below threads that configures various modes of embedded syncs which includes 480p60?

    no video output from ADV7513 

    Best Regards,

    Jeyasudha.M

  • Hi

    Thank you for your reply

    1) I have EVAL with ADV7513 from altera

    2) Yes

    3) I tried to find out a script for "YCbCr 422, 480p 2x clk, de enable" but could find only :

     

    :8-bit bus separate syncs DE,VS,HS
    40 03 00 ; 8-bit SDR ITU-656 mode
    40 04 42 ; OP_CH_SEL
    40 05 28 ; AV Codes Off
    40 19 C3 ; LLC_DLL_EN, LCC_DLL_DOUBLE, LCC_DLL_PHASE
    72 15 03 ; Input ID 8-bit 2x Pixel Clock, Sep. Syncs
    72 16 79 ; 8-bit color
    72 17 00 ; DE off, sync polarity (##### I use DE on #####)
    72 48 00 ; even adjust
    End

     

    or 

     

    :480p60 8-bit bus embedded syncs
    40 03 00 ; 8-bit SDR ITU-656 mode
    40 04 42 ; OP_CH_SEL
    40 05 2C ; AV code on
    40 19 C2 ; LCC_DLL_DOUBLE
    44 7B 05 ;
    72 15 04 ; 8-bit 422 2x clock embedded syncs (##### I use Seperate sync #####)
    72 16 79 ; 8 bits, Style 1
    72 17 61 ; gen de
    72 48 00 ; evenly justified,
    ;; Enable 7511 sync regenerators
    ;; reference Table 33,34,35
    72 30 04
    72 31 03
    72 32 E0
    72 33 24
    72 34 06
    72 35 1E
    72 36 64
    72 37 05
    72 38 A0
    72 39 1E
    72 3A 00
    72 D7 04
    72 D8 03
    72 D9 E0
    72 DA 24
    72 DB 06
    72 DC 00
    72 DD 00
    72 FA 00
    72 FB 00
    End

     

     

    can you share script that meant VIC #15 which is "YCbCr 422, 480p 2x clk, de enable"

  • 0
    •  Analog Employees 
    on Jun 22, 2017 6:11 PM

    Hi,

    Sorry for the delay. We are checking with part specialist on this one and will update you soon

    Best Regards,

    Jeyasudha.M

  • Have you tried probing the HS and VS lines to ensure that you are indeed not sending the chip 480p120 from your video source?  Is VS toggling at 60Hz like it should be for VIC=15, or 120Hz?  Is HS toggling at 31.5kHz (correct for VIC=15) or 63kHz (VIC=49)?  I've run into cases before where I've modified the H/V rate in too many places and ended up getting the wrong CEA VIC as a result.

  • Hi every one

    Thanks for reply,

    I'm sending exact 60hz vsync with 31.5khz hsync, The problem is that i couldn't find how to config the parameters so the ADV7513 will support vic#15.

     

    Thanks

    Gil