ADV7280A-M MIPI output abnormal

Dear Specialist,

       We've debugging ADV7280A-M for month. Now we can get MIPI output following the web documents guidance. However, seems the image is mirror or need to be rotated.

Can you advice how to correct the image. Does modify any register can help, or it can only be solved from MCU side. 

Parents
  • +1
    •  Analog Employees 
    on Nov 5, 2020 7:50 AM 3 months ago

    Hi,

      As per expert comment "Video decoder digitizes the incoming analog video. It does not reverse or flip the image.
    In some designs the processor may be needed to reverse the image depending on the input/camera usage. For example reversing camera vs. frontview camera"

     Please note that ADI does not have a chip to do this or any commercially available chips that does.  

    Thanks,

    Poornima

  • Dear Poornima,

             Thanks for replay, we debug this chip for days, we are very colsed to successfully get MIPI out with ADV7280A-M. 

    Now only one confuse, during preview occasionally the image crash as below, can you advice the possible reason of this phenomenon.

  • hi ,

        Follow you advice, the screen won't be burn in interlaced mode when camera prievew; But our customer require adv7280m output size 720*576, this nend to enable I2P, so please help me  to find the root cause of the flash screen appearing in the camera preview ! thanks a lot !

  • 0
    •  Analog Employees 
    on Nov 18, 2020 6:40 AM 3 months ago in reply to songyantao

    Hi,

     Since you have reported, "This issue is not happened every time", So we suspected like some other functionality may causing this issue,

     Due to this only we have suggested you to disable the I2P conversation, we thought this might causing the issue for once.

     Also can you check with direct connection without using the board and check with other cameras also .

    Thanks,

    Poornima

  • hi 

     We use other cameras, it also has the same problem "blurred screen Occasionally   " !   Can you help me check the registers config have any other question for 720*576 size ! tks!

    ##03_CVBS AUTODETECT, Progressive Out##
    :I2P AUTODETECT CVBS Single Ended In Ain 1, 480p/576p MIPI Out:
    delay 10 ; Wait 10ms After Hardware Reset To Start I2C
    42 0F 80 ; Reset ADV7280A-M
    delay 10 ; Wait 10ms
    42 0F 00 ; Exit Power Down Mode
    42 52 CD ; AFE IBIAS
    42 00 00 ; INSEL = CVBS in on Ain 1
    42 0E 80 ; ADI Required Write
    42 9C 00 ; Reset Current Clamp Circuitry [step1]
    42 9C FF ; Reset Current Clamp Circuitry [step2]
    42 0E 00 ; Enter User Sub Map
    42 80 51 ; ADI Required Write
    42 81 51 ; ADI Required Write
    42 82 68 ; ADI Required Write
    42 17 41 ; Enable SH1
    42 03 4E ; Power down unused pads
    42 04 57 ; Power-up INTRQ pin
    42 13 00 ; Enable ADV7280A-M for 28_63636MHz crystal
    42 1D C0 ; Tri-State LLC output driver
    42 FD 84 ; Set VPP Map Address [I2P]
    84 A3 00 ; ADI Required Write [I2P]
    84 5B 00 ; Advanced Timing Enabled [I2P]
    84 55 80 ; Enable I2P [I2P]
    42 FE 88 ; Set CSI Map Address
    88 01 20 ; ADI Required Write [I2P]
    88 02 28 ; ADI Required Write [I2P]
    88 03 38 ; ADI Required Write [I2P]
    88 04 30 ; ADI Required Write [I2P]
    88 05 30 ; ADI Required Write [I2P]
    88 06 80 ; ADI Required Write [I2P]
    88 07 70 ; ADI Required Write [I2P]
    88 08 50 ; ADI Required Write [I2P]
    88 DE 02 ; Power up D-PHY
    88 D2 F7 ; ADI Required Write
    88 D8 65 ; ADI Required Write
    88 E0 09 ; ADI Required Write
    88 2C 00 ; ADI Required Write
    88 1D 80 ; ADI Required Write [I2P]
    88 00 00 ; Power up MIPI CSI-2 Tx  [All ADV7280A-M Writes Complete]
    End
  • 0
    •  Analog Employees 
    on Nov 19, 2020 5:40 PM 3 months ago in reply to songyantao

    Hi,

     Your configuration was perfect as per recommended script. Please let me know, in which controller you are interfacing with ADV7280A-M ?

    Thanks,

    Poornima

Reply Children
  • 0
    •  Analog Employees 
    on Nov 20, 2020 10:42 AM 3 months ago in reply to songyantao

    Hi,

     I haven't hear this CX1881.

     We don't face any issues in our eval, I don't know where it is going wrong in your side.Please make sure whether CX1881 has been configured correctly according to ADV7280A-M.

     Could you please use one delay alone instead of using two 10 ms delay,

     delay 10 ; Wait 10ms
     42 0F 00 ; Exit Power Down Mode

    Thanks,

    Poornima

  • hi

      we have used one delay after reset !  You said first delay may be the reset pin is pulled up !

  • 0
    •  Analog Employees 
    on Nov 23, 2020 10:24 AM 3 months ago in reply to songyantao

    Hi,

      But in your shared script seems, you have added one more delay before ADV728x chip reset.

      Please note that As per expert comments "Two 10ms waits are overly conservative.  The first reset can occur as soon as the power rails become stable with a pulse width of ~1ms.  The hardware reset just pushes all the registers to their default state.
    The second software reset needs ~1ms for all registers to return to their default state.
    In reality even 1ms maybe too long, it's just a safe delay to work with.  The second reset probably does not need any delay since the actual reset ripples through faster than the I2C master can write another command.
    If you have a working system I'd experiment by removing the software reset right after the hardware reset and see if the chip operates as expected.  I have not tried this.
    The software reset can be used after power up if the system has no way to drive the hardware reset".

    Thanks,

    Poornima

  •   /* Reset */
      ret = adv7280_write_reg(client,
       ADV7280_POWER_MANAGEMENT, 0x80);//0xA0//check set1
      if (ret < 0){
       SENSOR_ERR("#1#adv7280_reg_init ADV7280_POWER_MANAGEMENT error!");
       goto err_unreg_subdev;
      }
      msleep(10);

    hi

     Do you  mean the soft reset does not need 10ms ?  Thanks !

      

  • +1
    •  Analog Employees 
    on Nov 30, 2020 10:57 AM 2 months ago in reply to songyantao

    Hi,

     Yes, A software reset does not require a time delay. The hardware reset will set all registers to their default state and reset the I2C engine.

     Please note that 5ms reset delay is usually associated with the hardware reset. For hardware reset it is best to keep reset low until the power rails are stable.  Normally this can be accomplished with a simple RC circuit on the reset pin.

    Thanks,

    Poornima