adv7181D decode VGA (640 x 480 @60Hz) to 8 bit YUV 422

PCBWe are currently using an ADV7181D to decode VGA (640 x 480 @60Hz) to 8 bit YUV 422.But there is no register

configuration in the script you provided.So I want to ask you something:

1、Does it support doing that  to decode VGA (640 x 480 @60Hz) to 8 bit YUV 422.

2、If yes,could you provide such a script.

  • +1
    •  Analog Employees 
    on Sep 6, 2019 12:35 PM over 1 year ago

    Hi,

     Yes,there is no configuration script available for VGA to YUV 422 . But you can configure 8bit YUV 422 in register 0x03(OF_SEL) . It allow the user to choose different output format in 8bit,10bit,16bit,20bit in YUV 422.

    Thanks,

    Poornima

  • Thanks for your reply!It works well when we use CVBS signaling,but it didn't work when decoding the VGA signal.We may only use 8bit YUV422 format for hardware reasons.The register 0X03 allow us to choose different output format,but I don't know how to set the other registers because these Settings are professional.So could you provide such a new script and inform the configuration process?

  • Thanks for your reply!It works well when we use CVBS signaling,but it didn't work when decoding the VGA signal.We may only use 8bit YUV422 format for hardware reasons.The register 0X03 allow us to choose different output format,but I don't know how to set the other registers because these Settings are professional.So could you provide such a new script and inform the configuration process?
  • 0
    •  Analog Employees 
    on Sep 10, 2019 9:39 AM over 1 year ago in reply to Three

    Hi,

    Please try below configuration for VGA input to 8bit YUV 422.

    42 05 02 ; Prim_Mode =010b for GR
    42 06 08 ; VID_STD=1000b for 640x480 @ 60
    42 C3 31 ; ADC1 to Ain5 (R), ADC0 to Ain2 (G),
    42 C4 F2 ; ADC2 to Ain3 (B), enables manual override of mux, use SOG
    42 1D 47 ; Enable 28MHz Crystal
    42 3A 11 ; set latch clock settings to 001b, Power Down ADC3
    42 3B 81 ; Enable Internal Bias
    42 3C 5C ; PLL_QPUMP to 100b
    42 6A 00 ; DLL Phase Adjust
    //42 6B 84 ; Enable DE output, swap Pr& Pb
    //42 C9 08 ; Set DDR_EN
    42 73 90 ; Set man_gain
    //42 7B 1D ; TURN OFF EAV & SAV CODES Set BLANK_RGB_SEL
    42 03 0C ; 8 Bit Mode - Added
    42 85 03 ; Enable DS_OUT
    42 86 0B ; Enable stdi_line_count_mode
    42 8A 90 ; VCO Range to 00b
    42 F4 3F ; Max Drive Strength
    42 0E 80 ; ADI Recommended Setting
    42 52 46 ; ADI Recommended Setting
    42 54 80 ; ADI Recommended Setting
    42 0E 00 ; ADI Recommended Setting
    42 52 80 ; ADI Recommended Setting
    42 57 08 ; ADI Recommended Setting
    42 5B 00 ; ADI Recommended Setting
    42 5C 01 ; ADI Recommended Setting
    42 62 20 ; ADI Recommended Setting
    42 63 00 ; ADI Recommended Setting
    42 67 03 ; ADI Recommended Setting
    42 68 01 ; ADI Recommended Setting

    Thanks,

    Poornima

  • Hi,

        First of all, thanks for your reply!

        I tried this configuration on my device.Unfortunately, the effect was not what I expected.

    This picture is the effect that I used this configuration, but no VGA signal was connected.And whether you connect the signal or not, that's the state.