ADV7612- AVMUTE

Hi,

Customer reports an issue on ADV7612 that AVmute(IO map 0x65[5]) is set if they swap the input port port-a <--> port-b by setting HDMI_PORT_SELECT HDMI map 0x00[2:0], meanwhile, there is only one port is connected and the other port leaves unconnected. It happens occasionally and only can be reproduced with their DVD player with 3D output, that means when DVD player set to 2D output it will be no problem.

We dump the ADV7612 register setting as attached, and found the AVMute is set. We tried to disable the "EN_BG_PORT_A" and "EN_BG_PORT_B" then the issue can be solved.

Can you please advise what's happened for this issue as if we disable the BG mode then the fastswitch function will also be disabled.

Steven

dumpingHDMI.xlsm
  • 0
    •  Analog Employees 
    on Mar 13, 2012 6:28 PM

    Hi Matt,

    It was found on customer's platform for projector application. It seems only can be reproduced on some Blue-ray players with 3D (side-by-side or top-bottom...)output. I just borrowed one blue-ray machine from customer and will do some experiments on EVAL-ADV7612-7511. I will get back to you once I find something wrong.

    Steven

  • 0
    •  Analog Employees 
    on Mar 14, 2012 4:00 AM

    Hi Steven,

    I tried to reproduce this behavior using EVAL-ADV7612-7511 and AVES register-editing software.

    1. I start with HDMI generator connected to port A and nothing on port B. The board is passing 480p/60 HDMI signal okay.

    2. I read IO map 0x65 and I see 0x8E.

    3. I change HDMI_PORT_SELECT register from port-A to port-B

    4. I read IO map 0x65 and now I see 0x40 (HDMI_MODE_RAW = 0 and INTERNAL_MUTE_RAW = 1).

    5. I change HDMI_PORT_SELECT register from port-B to port-A

    6. I read IO map 0x65 and now I see 8E again.

    Can you share some more information about this platform? Is it running some application software? Or are they just configuring ADV7612 with scripts?

    -Matt

  • 0
    •  Analog Employees 
    on Aug 2, 2018 4:33 PM
    This question has been assumed as answered either offline via email or with a multi-part answer. This question has now been closed out. If you have an inquiry related to this topic please post a new question in the applicable product forum.

    Thank you,
    EZ Admin