ADV7282A-M on custom Jetson TX2i board

Hello,

I have a custom board based on a Jetson TX2i, and I would like to use the ADV7282A-M for acquiring images from an analog source.

I have managed to successfully get the test pattern from the chip with the command:

v4l2-ctl -d /dev/video0 -w --verbose --set-fmt-video=width=720,height=576,pixelformat=YUYV --stream-mmap --stream-count=300 --stream-to=test.raw

However, when I connect a signal generator (Phabrix SX) to the AIN1 and I disable the free running pattern, I only acquire a black screen (with "noisy" pixels) with a green band on the right, as in the image below.

I have gone through your list of I2C commands, manually tried many of them, triple-checked that the INSEL bits are properly configured for the CVBS input on AIN1, but nothing, still the same issue.

Since the test pattern seems to work, I tend to believe that the driver side is ok (but I've taken the driver from this post on the Jetson forum and took it up to speed with the latest commits to the kernel mainline, thus I wouldn't bet my life on it...), and that I am missing something on the configuration side of the chip.

Does the image above ring any bell? What could I be missing?

Thanks in advance!

Best,

Rob