AnsweredAssumed Answered

How can I use the FTDI cable to program AD9548 using SPI?

Question asked by mko on Oct 2, 2017
Latest reply on Oct 2, 2017 by pkern

Hello, I am using an FTDI cable to control an AD9548 chip using SPI interface.  All reading operations of the chip's register is successful and I seem to have no problem with reading operations but when I try to write the chip's registers I cannot read the written values back and I get the values the was stored in the registers before issuing the write operation!.

 

Here is what I have:

An FTDI cable connected to the AD9548 on one of our custom boards with the following connections

Cable <-------> AD9548

SK <-------> SCLK/SCL

DO <-------> SDIO

DI <-------> SDO

CS <-------> CS/SDA

 

I tried to write 0x99 to register 0x0000 which I believe is an active register and doesn't need an input/output update to make effect but when I read it back I got 0x18 (the value which was stored before) and I have the same issue with all the registers I have tried to write into even with issuing an i/o update after reading. I didn't shutdown or reset the chip between the write operation and read operation.

 

Can you please give me a hint of what I am missing here?

 

Best regards,

MKO

Outcomes