AnsweredAssumed Answered

Problems with ad9361 makefile (xsct: error: illegal option '-s')

Question asked by Luis_P on Sep 28, 2017

Overview:

I'm trying to run the example no-os command line application on the fmcomms3 board, which comes with the ad9361, plugged in the kc705 xilinx board. For this, i installed vivado 2016.2 suite, which is the version recommended in the release notes for the HW version 2016_r2~, and configured the PATH variable as the following:

 

set path=($path $xilinx_dir/xilinx/Vivado/2016.2/bin)
set path=($path $xilinx_dir/xilinx/Vivado_HLS/2016.2/bin)
set path=($path $xilinx_dir/xilinx/SDK/2016.2/bin)
set path=($path $xilinx_dir/xilinx/SDK/2016.2/gnu/microblaze/nt/bin)
set path=($path $xilinx_dir/xilinx/SDK/2016.2/gnu/arm/nt/bin)
set path=($path $xilinx_dir/xilinx/SDK/2016.2/gnu/microblaze/linux_toolchain/nt64_be/bin)
set path=($path $xilinx_dir/xilinx/SDK/2016.2/gnu/microblaze/linux_toolchain/nt64_le/bin)
set path=($path $xilinx_dir/xilinx/SDk/2016.2/gnu/aarch32/nt/gcc-arm-none-eabi/bin)

 

I'm using CentoOS 7 linux operational system.

 

I download the ad9361 sw files from git: https://github.com/analogdevicesinc/no-OS/tree/master/ad9361

 

Well, after do all this processes, i tried to run the make all command inside de ad9361 directory but i get the following error:

creating project
xsct -s ../build_scripts/xilinx/create_sdk_project.tcl system_top.hdf sdk_project
error: illegal option '-s'
Usage: xsct [options] [tclscript] [tclargs]
Options:
-interactive
Enter interactive mode after -eval or running script.
-help
Display this help message.
-no-ini
Do not load xsct.ini
-quiet
Start XSCT in silent mode
-eval tclcommand
Execute <tclcommand> then exit

make: *** [sdk_project/workspace/sw/Debug/sw.elf] Error 1

 

Has domeone already faced this problem? How can i fix it?

 

Best regards.

Outcomes