AnsweredAssumed Answered

ADV7513 Issue on Some TV with BT-656/SPDIF

Question asked by Captcha on Sep 20, 2017
Latest reply on Sep 21, 2017 by mattp

Hy,

i'm using the ADV 7513 with a video source BT-656   and SPDIF audio source.

The output is configured for HDMI.

 

The #BT-656 stream is a #720x480i (NTSC) with embedded synchro.

The audio source is 44.1KHz SPDIF.

 

We have tested on many TV (Samsung, LG, Sony etc..and it works well, but on some TV (different model from Samsung & Philips) the audio is cut and the video some time disappear (watch the video with a blue pattern and audio).

We have verified that those TV accept normaly the 720x480i. 

 

 

 

My settings for the BT-656/SPDIF 

*********************************************************************************************************************

0x98, 0x03, // ADI recommended write*
0x9A, 0xE0, // ADI recommended write*
0x9C, 0x30, // ADI recommended write*
0x9D, 0x61, // ADI recommended write* ( no clock divided because progressive scan ex 1080p)
0xA2, 0xA4, // ADI recommended write*
0xA3, 0xA4, // ADI Recommended Write*
0xE0, 0xD0, // ADI Recommended Write*
0xF9, 0x00, // ADI Recommended Write*
0x49, 0xA8, // ADI Recommended Write*
0x9C, 0x30, // ADI Recommended Write*
0xE4, 0x60, // ADI Recommended Write*
0x01, 0x00, // Set 'N' value at 6272 for 44.1KHz
0x02, 0x18, // Set 'N' value at 6272 for 44.1KHz
0x03, 0x80, // Set 'N' value at 6272 for 44.1KHz
0x15, 0x04, // 8, 10, 12 bit YCbCr 4:2:2 (2x pixel clock, embedded syncs bt-656)

0x16, 0x35, // 8 bits, Style 2
0x17, 0x62, // disable DE gen, use SAV/EAV from stream

0x18, 0x46, // CSC disabled
0xD0, 0x32, // enable V & H gen

0x30, 0x04, // Register Settings for Embedded Sync Processing
0x31, 0xC3, // Register Settings for Embedded Sync Processing
0x32, 0xE0, // Register Settings for Embedded Sync Processing
0x33, 0x10, // Register Settings for Embedded Sync Processing
0x34, 0x03, // Register Settings for Embedded Sync Processing

0x41, 0x10, // Power down control
0x48, 0x00, // Data left justified
0x4C, 0x00, // 8 bit Output
0x55, 0x40, // Set YCrCb 444 in AVinfo Frame
0x56, 0x08, // Set active format Aspect
0x96, 0x20, // HPD Interrupt clear
0x9D, 0x61, // no clock divide
0xAF, 0x16, // Set HDMI Mode
0xBA, 0x70, // No clock delay
0x0A, 0x10, // CTS Auto, SPDIF mode
0x0B, 0x8E, // SPDIF enable, MCLK internal, default value
0x0C, 0x00, // I2S0,1,2,3 disable
0xD6, 0xD0, // HPD always on(power up possible if no HPD detected), TMDS Soft Turn on

*************************************************************************************************************************

 

We have try with pixel repetition but same issue.

  0x3B, 0xA0, // Pixel repetition in max mode (54MHz) for new TV

 

Any idea on this issue.

 

Thanks

Franck

Attachments

Outcomes