AnsweredAssumed Answered

No IP address with KC705+FMCDAQ2

Question asked by justinklchan on Jul 25, 2017
Latest reply on Jul 25, 2017 by justinklchan

My end goal is to run IIO scope on my host PC and control the FMCDAQ2. I followed the instructions on the Wiki to download a Microblaze and Linux Kernel image to the KC705.

 

Scenario 1

When the FMCDAQ2 is NOT placed on the KC705 board, the default IP address 192.168.2.2 is shown on the screen. I can ssh at that address as I set my computer to be on the same subnet, and IIO scope rightly detects the board and says there's no device, which is expected.

 

Scenario 2

However when I place the FMCDAQ2 into the HPC connector of the board and download the exact same images to the board again no IP address shows up on the screen.

 

All I get is a single underscore character like below.

In Scenario 1, I got this underscore character, but it went away and showed the IP address within a few minutes.

 

However, in Scenario 2 the screen appears to be stuck at this underscore character. It has been stuck like this for over an hour so I suspect there was something wrong with the kernel booting up. I tried to ping and ssh into the default IP address, but it fails.

 

How do I resolve this?

 

I tried to access the shell on the FPGA with the command:

sudo screen /dev/ttyUSB0 115200,8N1

however nothing shows up.

 

The Vivado tools and the images from Analog Devices are 2015.2. I am using Ubuntu.

Outcomes