AnsweredAssumed Answered

Can the Xilinx SDSoc Targeting Example be used for branch hdl-2016-r2?

Question asked by vecad on Jul 20, 2017
Latest reply on Jul 24, 2017 by ACozma

I tried using the SDSoC platform generation files here for HDL branch 2016 R2.

 

Xilinx SDSoc Targeting Example [Analog Devices Wiki] 


1)I skipped this step, since the HDL branch 2016 R2 should be updated for these changes.....or I could be wrong.

 

Update the HDL design to Vivado 2015.2 by running the sdsoc_platform/update_hdl.tcl script. This step needs to be ran only once after downloading the HDL reference design.


2)I used make -C library all to rebuild the libraries in HDL branch 2016 R2 with Vivado 2016.2

 

Regenerate the IP libraries following the steps described here: http://wiki.analog.com/resources/fpga/docs/hdl. This step needs to be ran only once after downloading the HDL reference design, or every time the IP libraries are modified.


3)I run into the following issue when running the sdsoc_platform.tcl script. I change the directory in Line 26 to C:/Xilinx/SDSoC/2016.2/platforms since I'm using 2016.2 version.

 

Generate the SDSoC platform by running the sdsoc_platform/sdsoc_platform.tcl script. Before running the script you need to edit it and change line 26 “set argv [list C:/Xilinx/SDSoC/2015.2/platforms]” to point to your SDSoC platforms folder. At the end of the process the new platform will be placed in the SDSoC platforms folder and will be named <board>_<carrier>, where <board> is the name of the FMCOMMSx board and <carrier> is the name of the Xilinx carrier, eg. fmcomms2_zc702


Problem:

When the script is performing BD connection in Vivado, the following error is generated.

 

connect_bd_net /clkdiv_reset/ext_reset_in
ERROR: [BD 41-701] connect_bd_net requires at least two pins/ports, or one pin/port and a net
ERROR: [BD 5-4] Error: running connect_bd_net.
ERROR: [Common 17-39] 'connect_bd_net' failed due to earlier errors.

 

    while executing
"connect_bd_net $m_name_1 $m_name_2"
    invoked from within
"if {[get_property CLASS $m_name_1] eq "bd_pin"} {
    puts "connect_bd_net $m_name_1 $m_name_2"
    connect_bd_net $m_name_1 $m_name_2
    return
  }"
    (procedure "ad_connect" line 47)
    invoked from within
"ad_connect clkdiv_reset/ext_reset_in sys_rstgen/peripheral_aresetn"
    (file "fmcomms2_bd.tcl" line 146)

 

    while executing
"source fmcomms2_bd.tcl"
    (file "system_bd.tcl" line 2)

 

    while executing
"source system_bd.tcl"
    (procedure "adi_project_create" line 98)
    invoked from within
"adi_project_create fmcomms2_zc706"
    (file "./system_project.tcl" line 8)
update_compile_order -fileset sources_1

 

Any help on how to resolve this?

thanks

Outcomes