AnsweredAssumed Answered

Issue with Makefile.zynq

Question asked by werty on Jul 18, 2017
Latest reply on Mar 6, 2018 by DragosB

Hello! I have ZEDBoard+AD-FCOMMS4-EBZ. Windows 10, Vivado2015.4.

I've got hdl and no-OS repositories from master branch of ADI Git-Hub. I run scripts and built hdl design. Then I use system_top.hdf from this design to built SDK project with no-OS/create_xilinx_sdk_project.bat at master · analogdevicesinc/no-OS · GitHub at f:\git\sl\fmcomms4\sdk\work. It's Okay!

Then I tried to build project using no-OS/Makefile.zynq at master · analogdevicesinc/no-OS · GitHub. There are two questions:

1. What "path_to_your" does exactly mean in no-OS/README.Build.txt at master · analogdevicesinc/no-OS · GitHub , line 19?

2. When I try to run no-OS/Makefile.zynq at master · analogdevicesinc/no-OS · GitHub using

C:\tmp\ad9361\sw>make -f Makefile.zynq

there is make error:

F:\git\sl\fmcomms4\sdk\ad9361\sw>set SDK_EXPORT=f:\git\sl\fmcomms4\sdk\work\workspace\SDK\SDK_Export\hw
F:\git\sl\fmcomms4\sdk\ad9361\sw>make -f Makefile.zynq
make: *** No rule to make target `system_top.hdf', needed by `bsp/ps7_cortexa9_0/lib/libxil.a'.  Stop.

Outcomes