AnsweredAssumed Answered

Error occurs when ADSP-SC573 read micro sd card

Question asked by jeffxu on Jul 12, 2017
Latest reply on Jul 18, 2017 by jeffxu

        we made one SC573 board ourselves,not EZ-KIT board.But Error occurs when linux read micro sd card,

uboot can read uImage and sc573-ezkit.dtb ,and linux run ok.

1.I have tried to lower mmc bus speed to 50M, the same error

2.I use 2 micro sd card ,one is Transcend card ,class 10,4GB, the other is kingston card ,class 4,4GB, also the same error

 

thank you very much

     error as below:

 

Driver 'mmcblk' needs updating - please use bus_type methods
Synopsys Designware Multimedia Card Interface Driver
dwmmc_adi mmc.0: num-slots property not found, assuming 1 slot is available
dwmmc_adi mmc.0: clock_frequency:-838890752
dwmmc_adi mmc.0: pdata->bus_hz33:0
clk->rate:0
clk->parent->rate:150000000
dwmmc_adi mmc.0: bus_hz2:50000000
dwmmc_adi mmc.0: IDMAC supports 32-bit address mode.
dwmmc_adi mmc.0: Using internal DMA controller.
dwmmc_adi mmc.0: Version ID is 270a
dwmmc_adi mmc.0: DW MMC controller at irq 84, 32 bit host data width, 1024 deep fifo
dwmmc_adi mmc.0: No vmmc regulator found
dwmmc_adi mmc.0: No vqmmc regulator found
dwmmc_adi mmc.0: 1 slots initialized
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
TCP: cubic registered
NET: Registered protocol family 17
do_initcall_level level 7
ThumbEE CPU extension supported.
mmc_host mmc0: Bus speed (slot 0) = 50000000Hz (slot req 25000000Hz, actual 25000000HZ div = 1)
mmc0: new SDHC card at address 1234
mmcblk0: mmc0:1234 SA04G 3.63 GiB
mmcblk0: error -110 sending status command, retrying
mmcblk0: error -115 sending stop command, original cmd response 0x900, card status 0x800b00
mmcblk0: error -84 transferring data, sector 0, nr 8, cmd response 0x900, card status 0xb00
mmc_host mmc0: Bus speed (slot 0) = 50000000Hz (slot req 400000Hz, actual 396825HZ div = 63)
IP-Config: Complete:
device=eth0, hwaddr=02:80:ad:20:31:e8, ipaddr=192.168.1.201, mask=255.255.255.0, gw=192.168.1.1
host=sc57x, domain=, nis-domain=(none)
bootserver=192.168.1.4, rootserver=192.168.1.4, rootpath=
ALSA device list:
No soundcards found.
Freeing unused kernel memory: 10516K (c04d3000 - c0f18000)
mmc_host mmc0: Bus speed (slot 0) = 50000000Hz (slot req 25000000Hz, actual 25000000HZ div = 1)
mmc0: tried to reset card
mmcblk0: error -110 sending status command, retrying
mmcblk0: error -110 sending stop command, original cmd response 0x900, card status 0x900
mmcblk0: error -84 transferring data, sector 0, nr 8, cmd response 0x900, card status 0x900
mmcblk0: retrying using single block read
usb 1-1: new high-speed USB device number 2 using musb-hdrc
mmcblk0: error -110 sending status command, retrying
mmcblk0: error -84 transferring data, sector 0, nr 8, cmd response 0x900, card status 0x0
blk_update_request: I/O error, dev mmcblk0, sector 0
Starting logging: mmcblk0: error -110 sending status command, retrying
mmcblk0: error -84 transferring data, sector 1, nr 7, cmd response 0x900, card status 0x0
blk_update_request: I/O error, dev mmcblk0, sector 1
OK
hub 1-1:1.0: USB hub found
Starting mdev...
hub 1-1:1.0: 4 ports detected
mmcblk0: error -110 sending status command, retrying
mmcblk0: error -84 transferring data, sector 2, nr 6, cmd response 0x900, card status 0x0
blk_update_request: I/O error, dev mmcblk0, sector 2
mmcblk0: error -110 sending status command, retrying
mmcblk0: error -84 transferring data, sector 3, nr 5, cmd response 0x900, card status 0x0
blk_update_request: I/O error, dev mmcblk0, sector 3
mmcblk0: error -110 sending status command, retrying
mmcblk0: error -84 transferring data, sector 4, nr 4, cmd response 0x900, card status 0x0
blk_update_request: I/O error, dev mmcblk0, sector 4
mmcblk0: error -110 sending status command, retrying
mmcblk0: error -84 transferring data, sector 5, nr 3, cmd response 0x900, card status 0x0
blk_update_request: I/O error, dev mmcblk0, sector 5
mmcblk0: error -110 sending status command, retrying
mmcblk0: error -84 transferring data, sector 6, nr 2, cmd response 0x900, card status 0x0
blk_update_request: I/O error, dev mmcblk0, sector 6
Starting watchdog...mmcblk0: error -110 sending status command, retrying

mmcblk0: error -84 transferring data, sector 7, nr 1, cmd response 0x900, card status 0x0
blk_update_request: I/O error, dev mmcblk0, sector 7
Buffer I/O error on dev mmcblk0, logical block 0, async page read
Initializing random number generator... mmcblk0: error -110 sending status command, retrying
random: dd urandom read with 15 bits of entropy available
mmcblk0: error -110 sending stop command, original cmd response 0x900, card status 0x900
mmcblk0: error -84 transferring data, sector 0, nr 8, cmd response 0x900, card status 0x900
mmcblk0: retrying using single block read
done.
Starting network...
/bin/sh: mmcblk0: error -110 sending status command, retrying
run-parts: not found
mmcblk0: error -84 transferring data, sector 0, nr 8, cmd response 0x900, card status 0x0
blk_update_request: I/O error, dev mmcblk0, sector 0
ssh-keygen: generating new host keys: RSA1 mmcblk0: error -110 sending status command, retrying
mmcblk0: error -84 transferring data, sector 1, nr 7, cmd response 0x900, card status 0x0
blk_update_request: I/O error, dev mmcblk0, sector 1
mmcblk0: error -110 sending status command, retrying
mmcblk0: error -84 transferring data, sector 2, nr 6, cmd response 0x900, card status 0x0
mmcblk0: error -110 sending status command, retrying
mmcblk0: error -110 sending stop command
Buffer I/O error on dev mmcblk0, logical block 0, async page read
mmcblk0: unable to read partition table

Attachments

Outcomes