AnsweredAssumed Answered

FMCOMMS3 + ZCU102 using no-os driver

Question asked by Valairian on Apr 28, 2017
Latest reply on Jul 13, 2017 by AdrianC

Hi all, 

 

I've been working for the past few weeks on interfacing an FMCOMMS3 Eval board with a ZCU102 - ES2 (Zynq UltraScale+ MPSoC) on Vivado and SDK 2016.4 for a school project. I managed to have, I think (or hope, i don't know :/ ), a functionnal design on Vivado. At least I don't have huge issue and have been able to generate a bitstream. 

 

I tried to use the provided Linux image but it seems that it's only working on the ES1 version of the board and because I don't have a ES1, I can't really run a test on it... Instead of waiting the next release for the ES2 (I saw somewhere around mid-year), I'd like to implement an soft on the board using the  no-os Driver API.

 

It seems, when I run the provided program without major changes (just some printf), that the fmcomms3 wouldn't be initialized. I assume, that something went wrong during the SPI initilization. To be sure, I've checked the good initialization of the SPI bus for the zcu102 and I don't have any errors  

 

I don't know if this code takes into account that the fmcomms3 is on the FMC connector. I assume not, because I didn't find any declaration or #define about that. How could I declare that ? I'm kind a newbie on developping code for a FPGA, I'm still a student after all , and I'm a little bit lost right know. 

 

Does anyone has an idea of what could be wrong or what kind of patch could I do ?

(I heard that someone in my school succeed to work with it last year but it was on a ZedBoard but not using no-os API ... )

Because the zcu102 is still an ES I could totally understand any Work in Progress stuff.  

 

Summary of my tools : 
 - Vivado 2016.4
 - SDK 2016.4
 - Fedora 20
 - ZCU102 - ES2

 

Thanks a lot ! 

 

Valérian

Outcomes