AnsweredAssumed Answered

HPUSB-ICE can't connect to BF514F16

Question asked by -DeeT on Mar 23, 2017
Latest reply on Apr 10, 2017 by Kader.M

I have built a board using an ADSP-BF514F16, and I'm unable to connect from VisualDSP++ 5.1.2 using an HPUSB-ICE JTAG emulator.  The error message is 0x80044005, and "Unable to halt processor" appears in gray text in the console window .  [Note: Since no other flavors of BF514 appear in the list, I used "BF514" as the processor type when creating the session.  Please let me know if this is correct.]

 

Here are the things I have checked and/or tried so far.

 

1. Confirmed that the same VisualDSP++ 5.1.2 and HPUSB-ICE are able to connect to another of our projects using a BF504F.  That works.

 

2. Ran the test in the Configurator tool.  This worked fine, with one JTAG device detected.

 

3. Tried using an ICE-1000 instead of the HPUSB-ICE.  No change.

 

4. Confirmed that all power supplies are correct:

                VDDINT 1.4v

                VDDFLASH 3.3v

                VDDOTP and VPPOTP 2.5v

                VDDEXT 3.3v

                VDDRTC 3.3v

                VDDMEM 3.3v

 

5. Boot mode is set for 010 (boot from internal SPI flash), but tried boot mode 000 (idle), to no avail.

 

6. Tried forcing the EMU pin low - didn't help.

 

7. Confirmed that the processor is not in reset (reset line at 3.3v), and that the CLKIN pin is receiving clocks (12.288 MHz, approx. 1.8v p-p).

 

I've scoured the data sheets and the schematic for the evaluation board, and haven't been able to find anything out of place.  Can anyone offer suggestions?

 

Outcomes