AnsweredAssumed Answered

U-boot does not start on BF609

Question asked by q2l on Mar 15, 2017
Latest reply on Mar 16, 2017 by Aaronwu

Hello.
I have custom board with BF609(ADSP BF609 KBCZ-5 2910594.1 - 0.2).
Reference designe was copied from EZKIT-BF609.
Same CLK, DDR and flash.
I compile the latest version of U-boot with bootable UART mode and with defines CONFIG_DEBUG and CONFIG_DEBUG_EARLY_SERIAL.
During the LDR-file booting,  board says

 

<p>BF 1B 00 00 41 42 61 63 43 61 62 63 64 65 66 67 6A 44 61 30 19 05 89 FF 21 65 47 61 E2 65 48 49 3E 0D 0A</p>

 

This means that the function 'initcode' from file ./arch/blackfin/cpu/initcode.c has been successfully completed.

 

After the booting the LDR-file is completed, the board does not respond(mute).

 

<p>

sudo /opt/uClinux2014R1-RC2/bfin-linux-uclibc/bin/bfin-linux-uclibc-ldr -TBF609 -l ./uboot_uart.ldr /dev/ttyUSB0
Loading LDR ./uboot_uart.ldr ... OK!
Opening /dev/ttyUSB0 ... OK!
Configuring terminal I/O ... OK!
Trying to send autobaud ... OK!
Trying to read autobaud ... OK!
Checking autobaud ... OK!
Autobaud result: 115200bps 23.961mhz (header:0xBF DLL:0x0D DLH:0x00 fin:0x00)
Sending blocks of DXE 1 ... [2/13] (15%)[board said:  ]
[board said: ��]
[board said: f]
[board said: �]
[board said: �]
[board said: �]
[board said: �f]
[board said: ��]
[board said: �]
[board said: �]
[board said:  ]
[board said: xf]
[board said: x]
[board said: ~]
[board said: �]
[board said: �]
[board said:  ]
[board said: `]
[board said:  ]
[board said: �]
[board said: � ]
[board said: �]
[board said: `]
[board said:  ]
[board said: �]
[board said: �]
[board said: �]
[board said:  ]
[board said: ��]
[board said: �]
[board said: `]
[board said:  ]
[board said: �]
[board said: �]
[board said: fx]
[board said: �]
[board said: �]
[board said: ��]
[board said: �]
[board said: �]
[board said:  ]
[board said: ��]
OK!           
You may want to run minicom or kermit now
Quick tip: run 'ldr <ldr> <devspec> && minicom'

</p>

 

If I booting the same file to the EZKIT-BF609 board, everything is fine(board starts and I get the console).

 

I have no idea what does it means.

 

Please help me.
Thank you.

Outcomes