AnsweredAssumed Answered

ADALM1000 on Raspberry Pi

Question asked by Jonnyjun Employee on Mar 15, 2017
Latest reply on Jun 16, 2017 by dmercer

Hello,

 

I tried to use ADALM1000 on Raspberry Pi.

I referred to Github for installing libsmu.

GitHub - analogdevicesinc/libsmu: Software abstractions for the analog signal exploration tools. 

 

First, I didn't use python script which is ALICE1.1 package .pyw code.(It has pythonpath error on script.)

When I tried to following command. It could work on ADALM1000 on Raspberry pi.

- Raspberry Pi2

- OS: NOOBS 2.3.0

 

******************************

<Setup software on Raspberry Pi>

apt-get install libusb-1.0-0-dev libudev-dev

apt-get install python2.7-dev

apt-get install cmake

git clone https://github.com/analogdevicesinc/libsmu.git

 

<Install libsmu>

cd ~/libsmu

cmake -DBUILD_PYTHON=ON .

cd /usr

sudo ldconfig

cd

sudo udevadm control --reload-rules

 

<Set pythonpath>

export PYTHONPATH=/usr/lib/python2.7/site-packages:${PYTHONPATH}

source ~/.bashrc

sudo make

sudo make install

 

<Implement Python code>

cd ~/ALICE

python alice-xxxxxxx

******************************

 

If I don't do "source ~/.bashrc", python script didn't work.(It has pythonpath error).

So, when I add the code(source ~/.bashrc), it could work the python code on Raspberry Pi.

However, if I close terminal window on Raspberry pi, it has pythopath error again.

If I do "export...." and "source..." command. It could work the script again.

It seems to reset the pythonpath setting by closing the terminal window.

 

Do you have any idea to fix the pythonpath of pysmu(libsmu)??

 

In addition, ALICE1.1 script didn't work from Python2(IDLE) which is IDE of Python on Raspberry Pi.

If I use ALICE on Raspberry pi, I have to use on terminal.

I checked pythonpath on Path Browser of the IDE. There is no path of libsmu.

 

I don't have enough experience to use Linux.

So, I don't know whether this pythonpath setting is spec of Raspberry Pi.

Please would you give me advice.

 

Thanks and best regards,

Jun

Outcomes