AnsweredAssumed Answered

EVAL-21479-EZLITE USB inteface red  in SigmaStudio for SHARC

Question asked by toani on Mar 8, 2017
Latest reply on Mar 16, 2017 by toani

Hello,

I have the following hardware:

ADZS-21479-EZLITE Revs DSP 0.2 BOM 1.5 PCB 0.1 with (JTAG Debugger) ADZS-SADA2-BRD DSP 0.2 BOM 1.5 PCB 1.0

ans software:

SigmaStudio 3.14.0 and SigmaStudio for Sharc PROD 2.2.0

I have set the DIP switches and Jumpers in the board as indicated in Sigmastudio_for_SHARC_Users_Guide.pdf Table 3, point 5.2.3.1 Settings for I2S mode:



I power the board, then connect the USB cable to the SADA2 board. Its orange LED lights up. I can see the board at the Device Manager. As for LEDs 1-8 they are all on. (I also tested different combinations of this sequence.)

   



I open SigmaStudio as adminsitrator. Then I opened the example project C:\Analog Devices\SoftwareModules\SigmaStudioForSHARC-SH-Rel2.2.0\Host\Examples\Sample Schematics\ADSP-214xx\ToneGen_Equalizer_Compressor_Block_214xx.dspproj. (I also created a new schematic, it displayed same issue.)

I have selected the loader file C:\Analog Devices\SoftwareModules\SigmaStudioForSHARC-SH-Rel2.2.0\Target\LDR\ss_app_sh479.ldr. (I used the .ldr that comes with the board support package. But I also recompiled this LDR
, same result).



The same error appears if I select Link/Compile/Download.

Whether I make a new schematic or open a new one, the USB box is highlighted in red and the issue persists.

I checked SigmaStudio_for_SHARC_Users_Guide.pdf where it suggests to check the connection.

But all looks fine with it. I know this device is working properly because it shows on the Device Manager (picture aboove), and it works for debugging in CCES (with the Same DIP and jumper configuration as above).



I deleted and re-added USBi several times. Tested in several computers, USB ports, and different power sequences before and after opening SigmaStudio.




I still see USB in red and cannot have the board running in SigmaStudio.

Would you please help me troubleshoot this?

Thanks

Outcomes