AnsweredAssumed Answered

Alsa driver  Enabled and Loading Issue

Question asked by svs on Mar 7, 2017
Latest reply on Mar 7, 2017 by svs

Hi All,

             I enabled the alsa library in buildroot for sc58x-ezkit-1.1.0. When loading uImage by tftp from ethernet, I got the following error...

 

sc # run ramboot
Speed: 100, full duplex
Using dwmac.3100c000 device
TFTP from server 172.17.8.144; our IP address is 172.17.8.79
Filename 'uImage'.
Load address: 0xc2000000
Loading: #################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#####################
1.7 MiB/s
done
Bytes transferred = 35613216 (21f6a20 hex)
Speed: 100, full duplex
Using dwmac.3100c000 device
TFTP from server 172.17.8.144; our IP address is 172.17.8.79
Filename 'sc58x-ezkit-hpc.dtb'.
Load address: 0xc4000000
Loading: ##
1.6 MiB/s
done
Bytes transferred = 18122 (46ca hex)
## Booting kernel from Legacy Image at c2000000 ...
Image Name: Linux-4.0.0-ADI-1.1.0
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 35613152 Bytes = 34 MiB
Load Address: c2008000
Entry Point: c2008000
Verifying Checksum ... Bad Data CRC
ERROR: can't get kernel image!

Outcomes