AnsweredAssumed Answered

Application is not running in CCES 2.1.0

Question asked by SKaranth Employee on Mar 7, 2017
Latest reply on Mar 24, 2017 by Kader.M

Hello,

 

I am using CCES 2.1.0 along with BLIP2-rev 2.0. After installing the BLIP2_BSP and the VideoOccupancySensing(VOS) from starweb, I tried building and running an example project - "VOS_Outdoors_realtime_BLIP2". After installing all the necessary add-ins I found that the project builds successfully, however when I try to run the project an error is encountered.

 

The problem I am facing is very similar to the question - "Application doesn't run on CCES 2.2.0 or CCES 2.3.0 or 2.5.0 ", however this is happening to me in 2.1.0. I haven't checked in the later versions.

 

As in the above question a particular custom proc.xml file is used in this example project too, and the same error with respect to the core_clock is being observed. 

>>>> We are setting the CORE Clock, SYSCLK, SCK0 and SCLK1 to the following values 384 MHz, 192MHz, 96 MHz and 192MHz.

>>>> But in Console I see the following values : 0, 384000000, 192000000, 96000000. 

 

After comparing the register values in proc.xml and in the CCES IDE, I found that many of them were not matching. So after starting the debug session, I put the break at main and manually changed the register values in the order given in the proc.xml file. When I then ran the code, I found that the code executed successfully. So we can conclude that somehow the proc.xml is not being uploaded/included when the debugging is being done .

 

The problem is that every time a new debug session is started, all the registers has to be re-written. Is there any easier fix to this? I have tried re-installing the CCES software but to see the same error. I would appreciate any and all the help offered in this regard.

 

Note: I have other versions of CCES(2.5.1, 2.5.0) installed in my system. Maybe this is causing the problem?   

 

Regards,

Sumanth N Karanth

Outcomes