AnsweredAssumed Answered

ADV7441A DVI output 256 gradation red gradient image There is a green vertical line in low gray

Question asked by baijunjie on Feb 28, 2017
Latest reply on Feb 28, 2017 by JeyasudhaMuthuPerumal

Hi,

 

I am using ADV7441 DVI receiver interface  and gives out 24bit RGB output. At the output display we are seeing change in some colors. ADV7441A DVI input 256 grayscale red gradient image, the output image appears in the low gray green line, as shown in the attachment diagram. The other color components are also not very clean. Following are my register settings, I am setting the RGB output with automatic CSC and the CP_OP mode . Is there any other setting that Im missing for this color problem to be solved.

 

 

0x42, 0x03, 0x0C, //; Disable TOD
0x42, 0x05, 0x06, //; Prim_Mode =0110b HDMI
0x42, 0x1D, 0x40, //; Disable TRI_LLC
0x42, 0x37, 0x01, //; Invert PCLK
0x42, 0x68, 0xF2, //; Auto CSC , YUV Out
0x42, 0x67, 0x01, //; Auto CSC , YUV Out

0x42, 0x6B, 0xE2, //; Setting cp_op_sel = 1 & Enable DE
0x42, 0xBA, 0xA0, //; Enable HDMI and Analog in
0x42, 0xC8, 0x08, //; Digital Fine Clamp Start position
0x42, 0xF4, 0x3F, //; Max Drive Strength
0x62, 0xF0, 0x30, //; ADI Recommended Write

0x62, 0xF1, 0x0F, //; ADI Recommended Write
0x62, 0xF4, 0xA0, //; ADI Recommended Write
0x6A, 0x15, 0xEC, //; Disable these mute mask bits
0x6A, 0x1C, 0x49, //; Set MCLKOUT to output 128fs
0x6A, 0x1D, 0x04, //; & Set Unmute Delay to 1_5 sec.

0x6A, 0x3C, 0x42, //; Set MCLKOUT to output 128fs
0x6A, 0x3D, 0x80, //; Change the VCO range for the audio PLL for 192KHZ sampling
0x6A, 0x5A, 0x01 //; Reset Audio Pll

Attachments

Outcomes