AnsweredAssumed Answered

Problem bringing up U-Boot on the ADSP-SC589 on the EZ-Board

Question asked by jon_harris8 on Feb 16, 2017
Latest reply on Jun 14, 2017 by pypardo

I'm trying to bring up U-Boot on the ADSP-SC589 on the EZ-Board. I'm following the instructions found in the Linux Added in User's Guide v1.1.0.  I've gone through the steps of running OpenOCD and then GDB.  I get to the last step in section 3.3 page 16 where it should actually start U-Boot on the EZ-Board.  U-Boot starts to run, but then hangs.  Here is what I see on the serial port output:

 

U-Boot 2015.01 ADI-1.1.0 (May 30 2016 - 14:25:12), Build: jenkins-IP119-UBOOT-STAGE-DEB-label=make_deb_package-248

 

CPU:   ADSP ADSP-SC589-0.0 (Detected Rev: 1.1) (spi flash boot)

VCO: 450 MHz, Cclk0: 450 MHz, Sclk0: 112.500 MHz, Sclk1: 112.500 MHz, DCLK: 225 MHz

OCLK: 150 MHz

I2C:   ready

DRAM: 224 MiB

MMC:   GRIFFIN SDH: 0

SF: Detected W25Q128BV with page size 256 Bytes, erase size 4 KiB, total 16 MiB

In:   serial

Out:   serial

Err:   serial

other init

Net:

 

Then it hangs indefinitely. I've tried the usual things of power cycling, unplugging the ICE, etc. but it always hangs right there.  I'm using the pre-built U-Boot image that came with the Linux Add In.

 

One other fact, the first time I tried this, it actually did start U-Boot and gave me the command prompt. I followed the instructions in section 3.4 to save U-Boot to SPI Flash. It connected to the TFTP server and successfully did the 'run update'.  Then I tried typing 'reset' and nothing happened.  Since then, U-Boot won't boot again, hanging at the spot indicated above.  I did make sure my rotary switch was set to #1 for SPI Master boot.

Outcomes