AnsweredAssumed Answered

Problem configuring eth0 as static

Question asked by LeroyKii on Feb 3, 2017
Latest reply on Feb 19, 2017 by rgetz

Hi,

 

I'm struggling to configure the network interface as static. I've tried two ways:

 

  • $ ifconfig eth0 192.168.168.10  ---> it works well, but sooner than later the configuration automatically disappears. I guess it has to do with some dhcp client. If that's the case, ¿how can I disable it?
  • Editing /etc/network/interfaces file:

# Config eth0 as static
auto eth0
iface eth0 inet static
       address 192.168.168.20
       netmask 255.255.255.0
       gateway 192.168.168.254

Somehow this config works okay but the problem is the PicoZed takes like 3-4 minutes to boot up. It gets stucked somewhere around these lines before proceeding:

Freeing unused kernel memory: 256K (c0718000 - c0758000)
This architecture does not have kernel memory protection.
Mount failed for selinuxfs on /sys/fs/selinux:  No such file or directory
 * Setting up X socket directories...       with status 1le              [ OK ]  <---- probably this
 * STARTDISTCC is set to false in /etc/default/distcc
 * /usr/bin/distccd not starting
 * Starting IIO Daemon iiod                                              [ OK ]

Outcomes