AnsweredAssumed Answered

Windows 10 Driver needed for AD5501/AD5504 evaluation board

Question asked by swift4096 on Dec 12, 2016
Latest reply on Dec 13, 2016 by msamera

I have just received the evaluation kit we ordered, but when I try to connect it to my system it will not load the necessary driver for the board to talk with the installed software. 

 

I installed the software first from the download on your site, AD5501_04_evalSoftware.zip.  I also tried removing and reinstalling the software from the included disc, though it appears to be the same installer.  I tried manually loading the four .INF files that were added to the windows\inf folder by the installer, but none of them have digital certificates so Windows 10 will not allow them to install that way.  If I try to manually update the driver from device manager, it does not find any applicable drivers.  When I remove the unknown device from device manager and rescan or unplug and plug it back in it goes through the motion of trying to install it, but no change is apparent in the device manager list. 

 

The software does not see any evaluation board present when loading.  The hardware ID of the unknown device is usb\vid_0456&pid_b231 if that helps you confirm it is recognizing the right device.  I found in another discussion a driver installer listed as ADI_PDA_Drivers.exe.  When run that seems to install a driver listed in device manager as EVAL-AD5501EBZ.  I can confirm the entry has the same hardware ID as the unknown device did previously so it is attaching to that device properly.  The software still loads indicating no evaluation board found with the name of the dialog listed as ":-13108".  If I select either AD5501 or AD5504 on launch it results in the same error.  The board itself is the AD5504 version as it has the 4 output channels.

 

The system is running Windows 10 Pro 64 bit if that is a factor.  I did try loading the software first without the additional PDA driver on another system also running Windows 10 with the same results.  The software installation runs properly without any complaints so it doesn't appear to be a compatibility issue for the software itself.  Since the PDA driver loads it appears to be compatible with Windows 10 as well.  Is there another driver that can be installed to correct this?

 

Thank you for any help you can provide.

 

*Update*

I was able to locate an older system with Windows 7 and confirmed the process it went through there to load the drivers worked.  I then ran the evaluation software in compatibility mode for Windows 7 on the Windows 10 system and the driver installer kicked off as it had on the Windows 7 system.  It appeared to load the same driver again even after I manually updated it from the C:\Program Files\Analog Devices\USB Drivers\PDA folder.  The evaluation software did recognize it this time and I was able to control the device through the UI as expected.

Outcomes