AnsweredAssumed Answered

Windows 10, using Vivado 2015.4.2 supplied make: fails to do anything, why?

Question asked by Ranzure_AllanD on Dec 4, 2016
Latest reply on Dec 5, 2016 by AdrianC

This is the output:

...\library\util_sigma_delta_spi>make
rm -rf *.cache *.data *.xpr *.log component.xml *.jou xgui *.ip_user_files *.srcs *.hw *.sim .Xil
c:\CAD\Xilinx1\SDK\2015.4\gnuwin\bin\rm.exe: cannot lstat `*.cache': Invalid argument
c:\CAD\Xilinx1\SDK\2015.4\gnuwin\bin\rm.exe: cannot lstat `*.data': Invalid argument
c:\CAD\Xilinx1\SDK\2015.4\gnuwin\bin\rm.exe: cannot lstat `*.xpr': Invalid argument
c:\CAD\Xilinx1\SDK\2015.4\gnuwin\bin\rm.exe: cannot lstat `*.log': Invalid argument
c:\CAD\Xilinx1\SDK\2015.4\gnuwin\bin\rm.exe: cannot lstat `*.jou': Invalid argument
c:\CAD\Xilinx1\SDK\2015.4\gnuwin\bin\rm.exe: cannot lstat `*.ip_user_files': Invalid argument
c:\CAD\Xilinx1\SDK\2015.4\gnuwin\bin\rm.exe: cannot lstat `*.srcs': Invalid argument
c:\CAD\Xilinx1\SDK\2015.4\gnuwin\bin\rm.exe: cannot lstat `*.hw': Invalid argument
c:\CAD\Xilinx1\SDK\2015.4\gnuwin\bin\rm.exe: cannot lstat `*.sim': Invalid argument
makefile:42: recipe for target 'util_sigma_delta_spi.xpr' failed
make: *** [util_sigma_delta_spi.xpr] Error 1

 

Yet running the commands work fine?

 

...\library\util_sigma_delta_spi>make -n
rm -rf *.cache *.data *.xpr *.log component.xml *.jou xgui *.ip_user_files *.srcs *.hw *.sim .Xil
vivado -mode batch -source util_sigma_delta_spi_ip.tcl >> util_sigma_delta_spi_ip.log 2>&1

 

then run the command:

...\library\util_sigma_delta_spi>vivado -mode batch -source util_sigma_delta_spi_ip.tcl >> util_sigma_delta_spi_ip.log 2>&1

...\library\util_sigma_delta_spi>

 

Producing all of the appropriate results!

Outcomes