AnsweredAssumed Answered

GNURADIO and FMCOMMS2/3/4 Sink cyclic option

Question asked by oclabbao on Nov 2, 2016
Latest reply on Dec 5, 2016 by mhennerich

Hello!

 

I wanted to transmit a non-periodic waveform with FMCOMMS3 using GNURadio.
So I started with cyclic-sine at iio-examples and modified for squarewave generation (grc.jpg). I also disabled the receive portion.

 

Using iio-oscilloscope (with Transmit/DDS set to Disable), I was able to observe (sort of) characteristic sinc plot of a squarewave (osc01.jpg). Please ignore amplitudes and noise, which is not my concern for now, as I was only viewing the signal over the air.

 

Then I set cyclic option to false in gnuradio, and I lost the sinc plot in iio-oscilloscope (osc02.jpg).

 

I re-tested with a sine wave, with cyclic set to on and off. Though I was getting the correct tone at LO+IF, the amplitude was fluctuating from no-signal to full-signal when cyclic is set to off (osc03.jpg). With cyclic set to on, the amplitude was more or less stable.

 

The cyclic setting is important because my goal is to be able to eventually transmit a non-periodic signal.

 

Transmitting a tone using iio-oscilloscope's Transmit/DDS seems to work well. Maybe I also need to mention that I'm running both GNURadio and iio-oscillocope remotely (a linux PC), and the FMCOMMS is mounted on a Zedboard connected over a local network.

 

Is there a setting I have missed, maybe in GNURadio or in iio-oscilloscope? Is what I'm trying to achieve actually doable in GNURadio+FMCOMMS?

 

Any help is appreciated. Thanks!

 

PS. I checked the forum thread below, but loopback isn't what I needed, only transmit.

GNURadio and AD-FMCOMMS4 Cyclic option set to false does not work 

Attachments

Outcomes