AnsweredAssumed Answered

SC589 -- SHARC to SHARC Audio when trying to impliment EE377

Question asked by MikeSmithCanada on Oct 30, 2016
Latest reply on Nov 20, 2017 by sonicretard

Hi,

 

I am upgrading my senior level university course from ADSP-21469 to the dual core SC589 eval boards.  Everything needs to be in place by Jan 12, 2017 or I can't afford to switch this year

 

I started to use the examples that came with cross-core -- looking for an audio talk through program that works with both 589 SHARC cores.  However there is the three core example where 1 SHARC talks to the ARM core, but not SHARC to SHARC talk.  Also I found an audio talkthrough program (which I got to work) but that was only one core.

 

I thought I had died and gone to heaven when I trolled an found EE377.pdf -- I can really make use of some of the material when I teach my course.

I also found a link to EE377v01.zip on one ez page --

BUT

 

I unzip, activate CrossCore 2.3.0 in the new workspace.  I get the message -- old format of the project.  I would really like to see these projects kept up to-date.  Nice first month job for a new university intern hire  -- :-)

 

Any way -- I click convert to new format -- total crash of the system -- CCES 2.3.0 exits with big log file.  I reactivate CCES 2.3.0 but it just shuts down with -- go look at error log messages

 

The error logs indicate some problems back in June 02, 2016

 

!ENTRY org.eclipse.core.resources 4 567 2015-06-02 23:01:00.902
!MESSAGE Workspace restored, but some problems occurred.
!SUBENTRY 1 org.eclipse.core.resources 4 567 2015-06-02 23:01:00.902
!MESSAGE Could not read metadata for 'RemoteSystemsTempFiles'.
!STACK 1
org.eclipse.core.internal.resources.ResourceException: The project description file (.project) for 'RemoteSystemsTempFiles' is missing.  This file contains important information about the project.  The project will not function properly until this file is restored.

 

Then some more June issues and then messages about my session

I deleted the workspace and tried again -- similar issues. 

 

So I tried plan C

I made a new directory -- copied files into it -- deleted the .metadata and imported the 3 projects.

Now I get large number of error messages about missing drivers

 

Went back and applied anti-Murphy Law Rule -- 3rd time lucky

!ENTRY org.eclipse.osgi 4 0 2016-10-30 09:39:50.716
!MESSAGE Application error
!STACK 1

Caused by: org.eclipse.core.internal.dtree.ObjectNotFoundException: Tree element '/RemoteSystemsTempFiles/.project' not found.

 

This time, I checked the directory structure this time -- I can find .project

 

So Plan D -- I opened not the workspace  MulticoreTalk with its meta file and Temp files, but the workspace above EE377 with its temp file directory

 

That opens -- but no projects are shown -- so I import those from the lower directory and get the message

 

2016-10-30 09:44:05, 052 [Thread: Worker-5] WARN - Add-in "12-Channel, 192 kHz, 24-Bit DAC (ADAU1962A) Driver (1.0.0)" installed in project "MultiCoreTalkThruSharcSharc_Core2" is NOT found.
2016-10-30 09:44:05, 067 [Thread: Worker-5] WARN - Add-in "ADSP-SC58x EZ-Kit Base Component (1.0.0)" installed in project "MultiCoreTalkThruSharcSharc_Core2" is NOT found.
2016-10-30 09:44:10, 008 [Thread: Worker-1] WARN - Add-in "Quad Analog-to-Digital Converter (ADAU1979) Driver (1.0.0)" installed in project "MultiCoreTalkThruSharcSharc_Core1" is NOT found.
2016-10-30 09:44:10, 022 [Thread: Worker-1] WARN - Add-in "ADSP-SC58x EZ-Kit Base Component (1.0.0)" installed in project "MultiCoreTalkThruSharcSharc_Core1" is NOT found.

 

Would appreciate some help

 

Regards

Mike Smith

Outcomes