AnsweredAssumed Answered

BF-609 and h264 encoder integration

Question asked by PrakashKumarMishra on Oct 16, 2016

I am trying to integrate the h264encbf609_Core0   BF-609 EZ-Lite  Kit. The original code was written with USB interface for FILE IO purposes but i changed the code to use ethernet interface for accessing any thing from the PC. 

 

One more reason why i have switched to Ethernet is because of non detection of USB OTG interface.

when i ran the example code i found following things on the console window.

I have already asked question for USB OTG not a single person answered anything. Plz guys help me.

 

For USB OTG i asked questiion with following headings

USB OTG  on BF 609 EZ-LITE Kit in ADSP-BF60x, plz find and answer that too.

 

Auto-detecting devices on the JTAG chain...

TDO <-----+
|
[0] - [ADSP-BF609 rev 0.2 from Analog Devices]
|
TDI >-----+
Loading application: "C:\Users\pkm\cces\2.0.0\examples\h264_bp_mpencoder.blackfin_4.1.0\H264 BPMP Encoder BF609\demo\ADSP-BF609-CCES\h264enc_Core0\Debug\h264encbf609_Core0.dxe"
Load complete.
Loading application: "C:\Users\pkm\cces\2.0.0\examples\h264_bp_mpencoder.blackfin_4.1.0\H264 BPMP Encoder BF609\demo\ADSP-BF609-CCES\h264enc_Core1\Debug\h264encbf609_Core1.dxe"
Load complete.

Core clock: 500000000 Hz
System clock: 250000000 Hz
System clock 0: 125000000 Hz
System clock 1: 125000000 Hz

System initialized
Configuring switches for the ethernet operation
Waiting for the link to be established
Link established
IP ADDRESS: 172.143.11.152
STDIO being redirected to file server on port 20000 of host 172.143.11.153

A non-recoverable error or exception has occurred.
Description: A data CPLB miss has occurred without a corresponding CPLB entry.
General Type: RunTimeError
Specific Type: DCPLBMissWithoutReplacement
Error PC: 0xc80a56dc

 

 

 

IN CASE of USB OTG 

The process which i have followed.
a) first i have run the application software and them two messages are being shown on my console screen of CCES

"Opening USB Device for STDIO ...

Output will be redirected to host device"

and then my code was waiting for a response from the PC side.

As mentioned in the user guide i ran a hostapp-cces.exe from PC using Command Prompt and sent a -u command.
As soon as i have clicked the enter button
some message came on the command prompt screen which i have attached as the screen shot.

pl let me know how to install the driver so that USB OTG will get detected by my PC.

 

 

 

Send screen shot describing various commands meaning

Outcomes