AnsweredAssumed Answered

subdir.mk file not being updated

Question asked by JohnC-vid on Sep 30, 2016
Latest reply on Oct 14, 2016 by Kader.M

CCES 2.2.0    Blackfin 706 project

 

My project has a virtual source sub-directory (Utils_70x) with 4 file references in it . I recently replaced one of these references with a new substitute file (different filename within the same source directory).

I have been building and running the debug build with no problems since the change.

I have just built the release build (no errors) and found some behavioural differences.  The problem is that the subdir.mk  in the release/utils_70x directory has not been updated, and is still building and linking with the old file, which no longer appears in my source tree!

 

I tried deleting the subdir.mk file. It is not re-created , but on performing a clean then build of the release I can see the subdir.mk files being recreated for all the other sub-directories (annoyingly these messages flash past very fast and are not present in the console window or build log) . The link fails due to none of the files in utils_70x being compiled.

 

How do I force re-creation of a correct subdir.mk file in all my sub-directories?

 

I have similarly tried deleting the subdir.mk directory for the debug build and t is correctly re-created. I have also tried adding and deleting files to the utils_70x virtual source folder, and again, the debug sub_dir.mk file is correctly re-created but the release version is not.

The /release make file definitely  has an entry "-include utils_706 subdir.mk

 

I have carefully looked through all the project settings and folder options and can find no differences (other than those expected) between the debug and release options

 

What is going on here? Has anyone else experienced this?

 

JohnC

Outcomes