AnsweredAssumed Answered

SC589 ss4s demo project

Question asked by walkercc on Sep 9, 2016

I test "XXX\SoftwareModules\SigmaStudioForSHARC-SH-Rel3.7.0\Target\Demo" project,
It can't output audio normaly.

So I want adi FAE can help me to solve the problem.

 

First of all. I use it by docs/AE_03_SS4G_QuickStartGuide.pdf,

But maybe something wrong.

 

1.I connected all line and power on. the led10 is light up.

how the led show the status when normal status and sigmastudio download ok.

 

2.when i use sigmastudio compile and download, i get result like below.
the message show " SSn ID: 0 (override)" , it's a error?

Compiler###### IC 1 ######

CrossCore? Embedded Studio v2.3.0
C/C++ Compiler : SHARC version 8.7.0.0 (May 27 2016 13:37:57)
Copyright (c) 1997-2016 Analog Devices, Inc.
Copyright (c) 1998-2014 Edison Design Group, Inc.
Copyright (c) 1997-1999 Edinburgh Portable Compilers, Ltd.

Compilation status of the source files:
IC 1_Volume_Mute_Block_SC5xx\Framework.c .... : Successful!
IC 1_Volume_Mute_Block_SC5xx\SSn.asm .... : Successful!
IC 1_Volume_Mute_Block_SC5xx\CModules.c .... : Successful!
IC 1_Volume_Mute_Block_SC5xx\Param.c .... : Successful!
IC 1_Volume_Mute_Block_SC5xx\SubProcessS1.c .... : Successful!

Schematic DXE successfully generated!
Application DXE used: D:\Analog Devices\SoftwareModules\SigmaStudioForSHARC-SH-Rel3.7.0\Target\Demo2\ADSP-SC58x\ADSP-SC589\SS_App_Core1\Release\SS_App_Core1.dxe

Memory usage of the modules in the schematic:

Instance Code Coeff Data32 Data48 Data32B Data32C CodeB
(bytes) (bytes) (bytes) (bytes) (bytes) (bytes) (bytes)
-----------------------------------------------------------------------------------------------------------------------------------------------------------
Signal I/P2 NA 24 0 0 0 0 NA
Mute1 NA 32 4 0 0 0 NA
Single 2 NA 36 8 0 0 0 NA
Mute5 NA 12 4 0 0 0 NA
Mute4 NA 12 4 0 0 0 NA
Mute3 NA 12 4 0 0 0 NA
Mute2 NA 12 4 0 0 0 NA
Mute6 NA 12 4 0 0 0 NA
Mute7 NA 12 4 0 0 0 NA
Output1 NA 0 0 0 0 0 NA
Output4 NA 0 0 0 0 0 NA
Output3 NA 0 0 0 0 0 NA
Output2 NA 0 0 0 0 0 NA
Output7 NA 0 0 0 0 0 NA
Output8 NA 0 0 0 0 0 NA
Framework NA 56 4608 0 0 0 NA
-----------------------------------------------------------------------------------------------------------------------------------------------------------
Total 5866 220 4644 0 0 0 0
-----------------------------------------------------------------------------------------------------------------------------------------------------------


MEMORY ALLOCATION

Buffer Address Size (bytes)
-------------------------------------------------------------------------------

FW Buffer 0 0x2C0AF4 6452
FW Buffer 1 0x300000 0
FW Buffer 2 0x200B0000 0

SS Buffer 0 0x200B0000 1024
SS Buffer 1 0x247DD0 5898
SS Buffer 2 0x200B0400 1024
SS Buffer 3 0x200B0800 4096
SS Buffer 4 0x2C2428 4708
SS Buffer 5 0x300000 796
SS Buffer 6 0x386B64 96
SS Buffer 7 0x80A00000 32
SS Buffer 8 0x386BC4 64
SS Buffer 9 0x80600020 64
SS Buffer 10 0x200B1800 64

SSn ID: 0 (override)

 

###### IC 2 ######

CrossCore? Embedded Studio v2.3.0
C/C++ Compiler : SHARC version 8.7.0.0 (May 27 2016 13:37:57)
Copyright (c) 1997-2016 Analog Devices, Inc.
Copyright (c) 1998-2014 Edison Design Group, Inc.
Copyright (c) 1997-1999 Edinburgh Portable Compilers, Ltd.

Compilation status of the source files:
IC 2_Volume_Mute_Block_SC5xx\Framework.c .... : Successful!
IC 2_Volume_Mute_Block_SC5xx\SSn.asm .... : Successful!
IC 2_Volume_Mute_Block_SC5xx\CModules.c .... : Successful!
IC 2_Volume_Mute_Block_SC5xx\Param.c .... : Successful!
IC 2_Volume_Mute_Block_SC5xx\SubProcessS1.c .... : Successful!

Schematic DXE successfully generated!
Application DXE used: D:\Analog Devices\SoftwareModules\SigmaStudioForSHARC-SH-Rel3.7.0\Target\Demo2\ADSP-SC58x\ADSP-SC589\SS_App_Core2\Release\SS_App_Core2.dxe

Memory usage of the modules in the schematic:

Instance Code Coeff Data32 Data48 Data32B Data32C CodeB
(bytes) (bytes) (bytes) (bytes) (bytes) (bytes) (bytes)
-----------------------------------------------------------------------------------------------------------------------------------------------------------
Signal I/P1 NA 24 0 0 0 0 NA
Mute1 NA 32 4 0 0 0 NA
Multiple 1 NA 12 4 0 0 0 NA
Multiple 1 NA 12 4 0 0 0 NA
Multiple 1 NA 12 4 0 0 0 NA
Multiple 1 NA 8 0 0 0 0 NA
Multiple 1 NA 12 4 0 0 0 NA
Multiple 1 NA 12 4 0 0 0 NA
Gen Filter1 NA 44 128 0 0 0 NA
Output1 NA 0 0 0 0 0 NA
Output2 NA 0 0 0 0 0 NA
Output3 NA 0 0 0 0 0 NA
Output4 NA 0 0 0 0 0 NA
Output5 NA 0 0 0 0 0 NA
Output6 NA 0 0 0 0 0 NA
Framework NA 76 4896 0 0 0 NA
-----------------------------------------------------------------------------------------------------------------------------------------------------------
Total 6240 244 5048 0 0 0 0
-----------------------------------------------------------------------------------------------------------------------------------------------------------


MEMORY ALLOCATION

Buffer Address Size (bytes)
-------------------------------------------------------------------------------

FW Buffer 0 0x2C0AF4 6452
FW Buffer 1 0x300000 0
FW Buffer 2 0x200A0004 0

SS Buffer 0 0x200A0004 1024
SS Buffer 1 0x247D48 6272
SS Buffer 2 0x200A0404 1024
SS Buffer 3 0x200A0804 4096
SS Buffer 4 0x2C2428 5112
SS Buffer 5 0x300000 820
SS Buffer 6 0x386B64 96
SS Buffer 7 0xC0A00000 32
SS Buffer 8 0x386BC4 64
SS Buffer 9 0xC0600020 64
SS Buffer 10 0x200A1804 64

SSn ID: 0 (override)


3. I can't be sure USBi connect corectly.
I use USBi to test ADSP-21369-EZKIT, it's ok.
and I connect USBi to P2 of the SC589-ezkit.
I only use 5 pins, pin5, pin7, pin8, pin9, pin10, and pin to pin direct connect.

SC589 ez-kit sw5 and sw6 is default setting. boot SW is set to position 0.

So what's wrong with me ? somebody help me to find the problem.

Outcomes