AnsweredAssumed Answered

AD5422 Voltage Output Delay Issue

Question asked by Photoman on Aug 16, 2016
Latest reply on Sep 26, 2016 by harryh


Hi, sorry in advance for the long post.  I figured too much info is better than not enough.  I have implemented the AD5422 in a design, and everything went relatively smoothly in development.  However, I have run across a problem in production. In some fully assembled samples, the analog output works nicely.  However, in others, there is an abnormal/unexpected delay before each device outputs the correct (meaning any) analog voltage. This delay is 5 seconds on some units, but can be as much as 3-4 minutes on others.  During this abnormal delay, the analog output from AD5422 stays near zero V out, and floats around a few millivolts of 0V.  Then after the delay, the Voltage (or current) output will jump to the expected value, and work correctly indefinitely.

 

A unit that operates normally will have a 2-3 second delay when power is applied, due to the microprocessor bootloader waiting for an input, and device initialization.  Call this the boot-up period.  However, with the devices exhibiting the problem, there is an additional delay of 5 seconds on some devices, up to 3-4 minutes for the worst case devices, before the analog voltage jumps from the previously described near-zero volt floating behavior to the proper output.  Interestingly, the amount of time between powering off and powering on affects the abnomal delay.  The shorter the pwr off, the shorter the abnormal delay.  In fact, on all problem units, when power is removed for up to 30 seconds, there is no abnormal delay.  After removing power for a longer period of time (60 seconds and beyond) the delay occurs, but is shorter than the worst case (full) delay, depending on the duration of the power off.  I have to leave the unit off a couple of hours before it exhibits the full abnormal delay.  For instance, when I power a device that was sitting overnight, it would give me a 3 minute delay for analog output.  But if I unpower for 10 seconds and power on, I only experience the boot-up delay (2-3 seconds) (i.e. no abnormal analog delay).   But if I unpower for 60 seconds, I might experience a 5 second abnormal delay.  If I unpower for 120 seconds, I might experience an abnormal delay of 20 or 30 seconds (this is just a rough guestimate, as I have not done any trials quantifying it).

 

There is an additional unusual phenomenon with only a couple units already experiencing the abnormal delay: after the 2-3 second boot delay, the analog output might jump briefly (split second) to the correct value, and return to the 0V floating condition, and after some period of time, jump to the correct output.

 

To me, this seems almost certainly a hardware problem, like some unwanted capacitance is charging, or an enable pin is not pulled correctly, or some type of leakage, etc.  The problem with diagnosis is these assemblies are permanently encased, and I can't get to the electronics anymore.  I need to investigate further on PCBAs not yet put in this encasing (I am getting some pulled out of stock). I do have a small amount of unassembled boards, but only one is exhibiting the issue, and on this one I measured all power supplies (and other voltages) at the pins of AD5422, and all were normal within a few milliseconds of power on.  I need to pull more PCBAs out of stock.  There doesn't seem to be a build problem, as I have examined this one board under a microscope.  Although the boards are stacked and I can't see the underside of the board, where there are several passives and a couple other chips.  The stacked boards are very difficult to separate (due to the headers), but I'm going to have to try.  But the signals that I CAN access through vias, etc. look good.  There is very little I can't probe.

 

Let me repeat again that I never experienced this phenomenon during development, and had quite a bit of testing on 16 boards, where I never saw the problem, and there were no changes to the PCBA from those protos to production boards, besides the fact that the proto boards were hand built by an outside board house, and the production boards are machine built.  And the firmware is the same.  Also, the first several production units worked as expected (no abnormal delay).

 

I have attached the schematic of the AD5422 portion of the design.  I am using both the voltage (+/-5V) and current output features of the device (Default is Voltage, but a production associate will switch it to current depending on the type of unit). I have implemented the op amp buffer into +Vsense per the app note.  The extra ground symbols mean these are analog grounds, (a separate ground plane, connected to the digital plane at one location).  My CAD program version did not allow separate/multiple ground planes, and had to get creative.  C27 was applied to pin 29, so I could later experiment with a HART modem.  But there is nothing connected to C27.  All caps are ceramic (non polar), even though the schematic shows the polarized capacitor symbol.

 

Enabling/disabling/enabling the AD5422 output via SPI during the abnormal delay does not make a difference, nor does changing between voltage and current output modes. The firmware constantly writes data to the data register, and I have tried all different values, from zero to 65000.  I can read back what I am writing to the data register, and it is correct. To the best of my knowledge, I followed Figure 69 of the data sheet correctly.  The fault pin is not wired to the microprocessor, but I probed this on a bare board and did not see a fault condition. The voltage fed into Vsense is correct (it floats within a few mV of zero V during the delay time), and matches the output.  I am sensing the voltage with an Agilent Digital Multi Meter.  I have implemented the OVRRNG function.  I do not have any firmware in place to report the status register, but I could implement that.  But the device is not hot (overtemp not a problem), and I am in the voltage mode, so IoutFault bit should not be set.  I can read the value stored in the data register, and it is consistent with the voltage I would expect out of the AD5422, and is consistent with the output voltage once the delay elapses.  During the abnormal delay, the device is otherwise working as expected.  I know this because a computer program monitors the unit digitally, and the unit reports a digital version of the analog output.

 

Any suggestions for things to try would be much appreciated.

Outcomes