AnsweredAssumed Answered

Remote ethernet connection linux host with zedboard/fmcomms3 failed second time

Question asked by mustafar on Jul 22, 2016
Latest reply on Aug 1, 2016 by pcercuei

Hi @ all,

 

i want to run a simple QPSK receiver in GnuRadio on the zedboard with fmcomms3-board connected.

Because the Polyphase Clock Sync, the CMA Equalizer and the Costas Loop require lot of processing power and the Zynq ARM core is probably to weak for that i want to compute the whole signal recovery stuff on a linux host notebook.

So i typed in the fmcomms-blocks the static IP-address of the zedboard and ran the block diagram on GnuRadio.

At first it all work properly and in the terminal following content appears:

 

     Generating: '/home/ubuntu/top_block.py'

     Executing: /usr/bin/python2 -u /home/ubuntu/top_block.py

     gr::log :INFO: controlport - Apache Thrift: -h ubuntu -p 37779

 

All worked fine for me.

But if i run the same block diagram a second time, following appears in the terminal:

 

     Generating: '/home/ubuntu/top_block.py' 

     Executing: /usr/bin/python2 -u /home/ubuntu/top_block.py 

     Traceback (most recent call last):

       File "/home/ubuntu/top_block.py", line 328, in <module>

       main()

       File "/home/ubuntu/top_block.py", line 316, in main

       tb = top_block_cls()

       File "/home/ubuntu/top_block.py", line 237, in __init__

      self.iio_fmcomms2_source_0 = iio.fmcomms2_source("192.168.0.1", LOfreq, samp_rate, 32 - 1, RFbandwidth,      True, True, False, False, Bufsize, True, False, False, "manual", 64.0, "manual", 64.0, "A_BALANCED", "")

       File "/usr/local/lib/python2.7/dist-packages/gnuradio/iio/iio_swig.py", line 212, in make

       return _iio_swig.fmcomms2_source_make(*args, **kwargs)

     RuntimeError: Unable to create context

 

     >>> Done (return code 1)

 

After i reset the zedboard, all worked properly again.

So maybe it has something to do with the ethernet protocol stack?

Could you please help me with that?

 

Thank you in advance!

 

regards,

Mustafa

 

Block diagram:

Outcomes