AnsweredAssumed Answered

ADV7511 HDMI Capture

Question asked by Glenn4462 on Jul 14, 2016
Latest reply on Aug 12, 2016 by Glenn4462

Hi,

I have a Finboard containing an Aptina MT9M114 camera, BF609 processor and ADV7511 HDMI encoder.  The YUV loopback demo supplied operates perfectly displaying to a BENQ GL2450 LED display via HDMI. The demo has been modified only to change (as per instructions), for Finabord hardware compatibility and the output to 720P60 (YUV422) for compatibility (on paper) with HDMI capture devices  (tried Atomos Ninja2 and Blackmagic Hyperdeck Shuttle 2) 

However I cannot get either of the capture devices to recognize the signal from the Finboard.

I have subsequently added a Neet HDMI splitter so I can have both the monitor and capture device connected simultaneously.  With this setup the display is perfect but the capture devices still refuse to recognize the signal.

The display's information menu confirms the signal to be 720P @ 60.

 

I have checked that HDCP is disabled in the ADV7511.  (the capture devices cannot accept HDCP encrypted video)

 

The YUV loopback demo uses the adi_adv7511 driver contained within the Video_Encoder_EI3_Extender_Board-Rel1.1.0 plugin to the CCES environment.

This is where all the register setup to the ADV7511 is performed, (apart from an override for Finboard specifics for right justification of Video input, and increase of colour depth from 8bit to 10bit)

I have tried disabling these two overrides to no avail.

 

Could anyone advise  where to look for a solution.

Getting a bit desperate now.

 

Thanks

Glenn

Outcomes