AnsweredAssumed Answered

Catastrophic error in prerequisite packages

Question asked by Exray on Jun 28, 2016
Latest reply on Jul 11, 2016 by Exray

Created an SD card with 1 April 2016 release (2015_R2)

 

Boot files in use are:

zynq-zc702-adv7511-ad9361-fmcomms5ZC702the on-board ADV7511 and the AD-FMCOMMS5-EBZ

 

Just connected it to the network, and it has a popup of new iio-oscilloscope 4.0, but I cancel so I can do the recommended update commands.  However, both are unsuccessful:

 

Welcome to Linaro 14.04 (GNU/Linux 4.0.0-g5e6cec4 armv7l)

 

 

* Documentation:  https://wiki.analog.com/ https://ez.analog.com/

 

 

Last login: Thu Jan  1 23:20:26 1970

root@analog:~#

root@analog:~# sudo adi_update_tools.sh

2016-06-28 22:00:28 URL: https://github.com/analogdevicesinc 200 OK

 

 

*** Updating linux_image_ADI-scripts BRANCH origin/master ***

HEAD is now at 5510971... adi_update_tools: Add 2015_R2 branch for colorimeter application

 

 

*** Building linux_image_ADI-scripts ***

./adi_update_tools.sh has been updated, switching to new one

2016-06-28 22:00:30 URL: https://github.com/analogdevicesinc 200 OK

 

 

*** Updating linux_image_ADI-scripts BRANCH origin/master ***

HEAD is now at 5510971... adi_update_tools: Add 2015_R2 branch for colorimeter application

 

 

*** Building linux_image_ADI-scripts ***

./adi_update_tools.sh script is the same, continuing

Reading package lists... Done

Segmentation faulty tree... 50%

Catastrophic error in prerequisite packages, please report error to:

https://ez.analog.com/community/linux-device-drivers/linux-software-drivers

 

I then try and update the boot files, and the latest is out of date:

 

root@analog:~# sudo adi_update_boot.sh

Verifying if ./adi_update_boot.sh is up to date...

HEAD is now at 5510971... adi_update_tools: Add 2015_R2 branch for colorimeter application

97dd9bc2a2c43f13bc5aed068fbf6c21

97dd9bc2a2c43f13bc5aed068fbf6c21

./adi_update_boot.sh is up to date, continuing...

--2016-06-28 22:04:51--  http://swdownloads.analog.com/cse/fpga_sd/latest_boot.txt

Resolving swdownloads.analog.com (swdownloads.analog.com)... 24.244.22.17, 24.244.22.32

Connecting to swdownloads.analog.com (swdownloads.analog.com)|24.244.22.17|:80... connected.

HTTP request sent, awaiting response... 200 OK

Length: 373 [text/plain]

Saving to: ‘latest_boot.txt’

 

 

100%[===================================================================================================================================================================================================>] 373         --.-K/s   in 0s

 

 

2016-06-28 22:04:52 (9.65 MB/s) - ‘latest_boot.txt’ saved [373/373]

 

 

CURRENT VERSION: boot_2015_r2_2016_03_15

NEW VERSION    : boot_2015_r1_2015_11_02

The current version is newer than the one that can be downloaded

 

Not sure if this has already been reported, the forum is still spinning its wheels when I select "More" to view more posts in this group.

Outcomes