AnsweredAssumed Answered

Y and Z axes are disabled (ADXL362)

Question asked by billbucket on Jun 27, 2016
Latest reply on Jun 30, 2016 by billbucket

I'm using a couple of ADXL362 development boards and can't seem to get anything but zeros for the Y and Z axes. The issue is with both the development boards and two replacement ADXL362 I reworked onto one of the boards.

 

I have tried reading the specific axes directly, burst reading all the axes, burst reading all the registers, saving to the FIFO and reading those values. I have also tried the test mode, the x-axis changes as expected, but again Y and Z are both zero.

 

In the case of the FIFO read, it appears that the FIFO isn't even storing the Y and Z axes. The samples all have 00 (x-Axis) for their header, unless I include temperature data, then the sample headers alternate between 00 (x-Axis) and 11 (Temp Data). It seems as if the Y and Z axes don't even exist.

 

I have attached screenshots from my digital logic analyzer. A full register burst read, an MSB axis burst read, a full bit-width axis burst read, and the FIFO read showing only x-axis values.

 

The EVB devices were marked as:

362X
#252
8303

 

The replacement ADXL was marked with:

362B
#611
9976

 

Is this a common failure? Is there some setting I'm missing? To my knowledge, I can't enable or disable the Y and Z axes, correct?

 

I'm not sure if AD has their distributors burn the ROM to downgrade dies to different part numbers, but it's the only explanation I can think of, since all these parts came from Mouser.

Outcomes