AnsweredAssumed Answered

How to calibrate FMCOMMS1 using IIO_SCOPE on Linux

Question asked by ttang on Jun 19, 2016
Latest reply on Jul 5, 2016 by ttang

Hi,

 

Our project uses FMCOMMS1 Rev.C board running no-OS driver, but we'd like to calibrate FMCOMMS1 using ADI's Linux tools such as IIO-SCOPE and xcomm_cal.

 

I downloaded 2015_R2-2016_04_01.img Linux image and started the iio-scope application.  After I click the "Calibrate" button,  a pop-up window appears with the calibration parameters.  It also has "Load from EERPOM" button, but it doesn't have a button to save the calibration parameters to EEPROM.  There are "Save to file", "Load from file", and "Apply Cal Data" buttons.  If I click "Apply Cal Data" botton, the EEPROM is not updated.

 

I can run "xcomm_cal" utility from the command line to find the EEPROM and display its entries, but when I try to save the calibrated parameters to EEPROM using "xcomm_cal -f 2245 -s /sys/...eeprom" command, the utility print an error message saying "iio_cmdsrv: not found".  Even after I run the script "start_srv.sh" to start iio_cmdsrv, xcomm_cal still prints the same error message.

 

My question is, how to calibrate FMCOMMS1 with ADI's linux tools?

 

Thank you for your support.

Best regards,

Tim

Outcomes